BMW E46 Fanatics Forum banner

1 - 20 of 20 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
Did a search on this already. Most people with retro fit xenon flickers. But my car came with xenon. They both started to flicker tonight after my rear left turn signal burned out. First time this happened.

Also flickers when it is parked. Comes a goes randomly. And both lights at the same time. So it can't be a bad bulb. Flickers when it is parked so can't be loose bulb. Help. :huh:
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Well coincidentally, the flickering started immediately after one of my rear turn bulb burned out. After I replaced the bulb, the xenon stopped flickering. It's been fine for a month now.
 

·
Registered
Joined
·
1,043 Posts
Mine have flickered intermittently. They are stock. They both do it at the same time. When it happens I'm paranoid the people in front of me will think I'm brighting them. It doesnt happen enough for me to worry about, plus I'm out of warranty, not going to worry about it.
 

·
Registered
Joined
·
12 Posts
Interesting, I have the same problem (both lights go off then immediately go on again). It's gotta be deep in the wires somewhere because both lights do it at once. Hasn't done it for days but it's flickered badly enough that I had to drive with just fogs - can't be good for the controller and bulbs to be flickering like that.

Maybe we could get some BMW people to watch this forum....
 

·
Registered
Joined
·
1,189 Posts
had the same exact problem... one of the bulb holders for my corner bulbs went bad... my xenons would just flicker out of nowhere... havn't happened since i changed the corner light bulb holder.... the corner bulb's gotta be tied to the xenons in some way....
 

·
Registered
Joined
·
12 Posts
Confirm on the turn signal

My car got hit by a tornado and for the repairs they took all the lights off, etc. to paint it. Then a month later or so I noticed the flickering in my xenons and noticed that there was a piece of masking tape underneath the driver's side fender turn signal. When I pulled on it the whole thing came out because the idiots broke the little clip that keeps that blinker in its slot. So I made a spring out of tape and a hairclip and it stopped flickering.

Now about 8 months later the flickering suddenly started, and quite a lot more frequently than before. I'm also worried about druken ******** thinking I'm flashing them. I can't be sure but I think a couple of times I saw my blinkers "sputter" but I can't seem to reproduce it. The hairclip holder I made is still holding tight so I guess I'm going to start systematically chaniging blinkers....

Anyone know how to check if the holder is bad? Is it a multimeter kind of think or more like trial and error? If I turn on the signals and do a walk around all of them are blinking fine so it's definitely a very delicate problem.

But what I've seen in other posts it seems that there are sometimes grounding issues involved with these xenons, and high-voltage systems seem to always amplify small grounding faults. Has anyone verified that grounding was an issue?
 

·
Damn Drivin' Fool!
Joined
·
1,945 Posts
Sorry to revive this old thread, but I'm just wondering if anyone really knows what the root cause of this "xenon flicker" syndrome is. Mine started doing it before the holidays, but it wasn't that bad. But now it just flickers non stop. I've had vehicles switch lanes to let me pass because they thought I was flashing them. LOL If I have to drive at night I usually just use the parking light/dayrunner/foglight combo to get from point A to point B.

FWIW, I purchase the whip new in 2001 and it's got over 90K on the clock. It's out of warranty and the extended warranty I purchased is not valid because the 3rd party company my local BMW dealer used or to issue the extended warranty went bankrupt. If this is an easy fix, I'd rather do it myself rather than take it in to the stealership.

BTW, just glancing over some handles here and I'm realizing I don't know any of you people. What happened to all the old school fanatics? Nevermind. You don't have to answer that.
 

·
Registered
Joined
·
2,422 Posts
that happened to me a couple months ago. Xenons and low beams were flickering like whatttt. Turned out the alternator was dead.

thank god for that warranty.
 

·
Registered
Joined
·
43 Posts
Has anyone found a real cause or fix for this? I had it happen a lot earlier this year and changed a few bulbs and had no problems until yesterday. Now I flash like a cop car coming down the street. Haven't found any "obvious" bulb problems. I work nights, so this is kind of a big deal. Took it to the dealer in January, and they couldn't find anything wrong.
 

·
Registered
Joined
·
1,338 Posts
Guys it could be due to alternator being overburdened with other accesories at night or the ballast maybe getting weak. The ballast is like the one on flourescent lamps. The bulb flickers until it comes on but once its on, its on till you have turn it off and turn it back on again. OR once the alternator looses charge, the xenons loses power and then tries to restart up again thus the flickering. I have a 2001 330i and I dont have that problem and hope I dont cos BMW electricals are as complex as the female mind...hahah
 

·
Registered
Joined
·
34 Posts
I don't think it has to do with the alternator because I just had a new one installed 2 days ago and tonight was the first time it happened. But it was alittle different for me. First the right xenon would turn off, then it would turn on but the left xenon would turn off and vice versa. It continued to do this for a while until the left one stayed on and the right one turned off. Turned the car off at starbucks...came back, turned the car on and they haven't done it since. What I did notice was that now I have one blue xenon and a white one.
 

·
Registered
Joined
·
11 Posts
My 2003 Touring Wagon is in the shop today to deal with the same issue. In my case, the left headlight flickers intermittently and sometimes goes out completely. I have to shut the vehicle down and retart it to re-light the Xenon. Until last week, it was just the left side. A few days ago, the right side started acting up. I'm guessing it is a bad ground somewhere but I will post an update when (if) I get the problem resolved.
 

·
Registered
Joined
·
39 Posts
Mine did the same thing. both lights same time, whenever it wanted to.
I went to dealer and they said 2800.00 to replace igniters and bulbs and lcm/
I told them no thanks
went home put two capacitors inline like the posts say and three nights now...
no flicker
try it. only about 10.00usd
 
1 - 20 of 20 Posts
Top