BMW E46 Fanatics Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
My 2001 320 cic
120,000 miles

I went to start my car the other morning and it fired very briefly then ran very rough for a few seconds than died. When I tried to restart it it just cranks over giving no indication of trying to fire.
This has happened a couple of times before but after letting it sit a while it would restart normally. Now it's been 3 days. The car was running normally up to this point.
Any suggestions?

Thanks
 

·
Registered
Joined
·
121 Posts
I would really recommend getting a code reader, in situations like this it can be anything (Ignition, Ignition Coils, leak, etc). Code Reader can save you a lot of time. I***8217;m talking from experience.

Hope everything works out for you.
 

·
Registered
Joined
·
722 Posts
autozone can read codes for FREE. However, if it does not start, you can't take the car there. Remove one of the plugs and leave it in the plug boot. Ask some one to crank it, during crank, look for sparks. If you have sparks, check the fuel pressure in the fuel rail. If you have no pressure, check for fuel pump fuse, relay, ect...
 

·
Registered
Joined
·
30 Posts
Discussion Starter #8
Autozones readers will only give the check engine light codes...so they say and my light was not on before this occurred.I hate the thought of having to have it towed and then be robbed you know.

Thanks
 

·
Registered
Joined
·
498 Posts
I had the same issue after I bought mine. Turned out to be a dirty starter connection. Cleaned it up and hasnt happened since.
 

·
Hawaii 3.0
Joined
·
5,373 Posts
sigh

try turning the key to the on position but dont crank. listen for the fuel pump to prime. If you don't hear it it could be the relay or the pump. To check the relay just open your glove box and turn the key to the on position again. listen for a click. If it doesn't click then the relay might be bad. just switch it with the horn relay to test. If it does click then it could be the pump

I've had this problem happen to me once with my E36 and once with my E46. The first time it was the pump, 2nd was the relay
 

·
Registered
Joined
·
30 Posts
Discussion Starter #14
Well I have spark, has to be fuel. I'm going to take the stupid route first, make sure it has enough fuel. I think I hear the pump relay clicking, but I guess I need to take the glove box out in order to check?
 

·
Registered
Joined
·
60 Posts
same thing happen to mine, still sitting in garage now for about 3 weeks. Just have'nt had the time to work on it :( I changed out the horn relay w/ the fuel pump relay still turn over but no start.. I do have a question tho if it was just a coil would'nt the car still start but just run bad?

Also Should i check the cam shaft sensor or the crankshaft sensor 1st?
 

·
Registered
Joined
·
30 Posts
Discussion Starter #17
I would think that would be the case. Dumb question...where are the relays located? I think I'll start there and work my way down the line.
I thought about cam sensor as well because it was suggested a while back by the dealer after sometimes when I would go into reverse the engine acted like it would stall but never did. Anyway to check the sensor?
 

·
Registered
Joined
·
60 Posts
You have to take out the glove box area and you can see the relays up in that area, there are 4 facing you.. the one on the far left is the fuel pump and the one on the far right (there are four 1 3 4 5) 1 being the fuel pump and 4 being the horn relay
 

·
Registered
Joined
·
30 Posts
Discussion Starter #19
Talk about some weird sh..
I figured I would start with the simple thing first. The car was showing between a little below a 1/4 tank. The car is sitting on a small incline with front of the car up hill so I figured that maybe the fuel wasn't reaching the pickup.I put 3 gallons of gas in and after trying several times it finally started but ran very rough along with some smoke out of the exhaust. I shut it off and restarted it and it fired right up so I took it for a little drive (1/4 mile) and it seemed Ok but my speedometer and mpg gauge do not work. The ABS and brake light stay on along with the yellow warning light which comes on with the traction control. Now I'm really lost!
 

·
Registered
Joined
·
60 Posts
damn i have no idea about that, atleast you can drive your car to the stealership lol :) now i would take it to autozone and let them pull any codes
 
1 - 20 of 24 Posts
Top