BMW E46 Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Need some help on fixing this problem....When I turn on the windshield defrost ever things to be working correctly, but my windshield doesn't defrost. I put my hand over the defrost vents and I am getting NO air coming out. It sound like the fan is blowing and there should be air, but there is none. What could the problem be and how can I fix it?
 

·
Registered
Joined
·
9 Posts
I am having the same problem. When I push the defrost button or hit the top vent button I get a clicking sound and no air. The air works fine on the middle and lower vents but no defrost. Where you able to figure out what was happening with your car? It's been 0 degrees in NH the last few days which has made driving a challenge without defrost. Any ideas are welcome.
 

·
Registered
Joined
·
6,317 Posts
Need some help on fixing this problem....When I turn on the windshield defrost ever things to be working correctly, but my windshield doesn't defrost. I put my hand over the defrost vents and I am getting NO air coming out. It sound like the fan is blowing and there should be air, but there is none. What could the problem be and how can I fix it?

I am having the same problem. When I push the defrost button or hit the top vent button I get a clicking sound and no air. The air works fine on the middle and lower vents but no defrost. Where you able to figure out what was happening with your car? It's been 0 degrees in NH the last few days which has made driving a challenge without defrost. Any ideas are welcome.



1. try unplugging the battery first.

2. if that doesn't work then you need to replace your HVAC climate control unit and luckily I just happen to be selling mine at the moment:

This is for the full automatic on/off version of the Auto Cabin Climate Control HVAC unit from a 07/01 Date 330i Premium Package car w/ 60,000 miles.

It is in MINT Excellent condition with no wear or scrapes anywhere from the buttons to the screen.

Asking $45 shipped. Paypal. You'll get free 2-3 Day USPS Priority Shipping with Tracking and the works














Item is in the Priority box as you are reading this ready to ship right this minute!






Here is my youtube video showing the EXACT unit you are buying:

http://www.youtube.com/watch?v=0nn4TqWdzuQ
 

·
Registered
Joined
·
17 Posts
Is this right? You can fix a flapper that isn't working by changing the control unit? I don't get air from the defrost vents and I thought I'd have to tear into the HVAC system to fix the vent. Has anyone else encountered this problem?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #5
Hey guys...did fix my problem and NO you do not have to replace the HVAC system. If you are getting air out of every area but one....meaning: face, floor, or defrost, then what I discovered should fix the problems. When I would change to defrost from face or floor, I would hear the vents to those locations close and hear the air change over to defrost, but no air would come out. My problem was that one of the small little motors of the defrost actuator came loose from its connection and was not opening the defrost flaps. The actuators of all the HVAC are behind the glove box towards the center console, or the center of the dash board. I think there are 3 actuators, one for each area, and 2 motors per actuator. The motors are the little round things that look a little bigger than a bottle cap. They clip into the actuator and have little motors in them with little teethed wheels. The motors spin the and the correct flaps are supposed to open and close. Check yours out and see if one of the motors are loose on the actuator, mine was and just by clipping it back in the housing the defrost started working.
 

·
Registered
Joined
·
4 Posts
I had the same problem for a while and had no idea what it was. It ended up being that i was low on coolant & only had enough to chill the engine. I was losing it very slowly through a hole on one of the hoses. Ended up replacing the hoses from the radiator to the motor and the water pump and now it works again and stronger than it was when i bought the car.
 

·
Registered
Joined
·
841 Posts
abrcrombtg--good feedback, and might be the answer to a problem I have--but not sure.
The AUTO control on the heater does not work for the FACE vent, but when it is taken off AUTO and put on MANUAL for the FACE vent it does work fine. When in AUTO I can hear the noise of the air, but very little coming out of the vent. Based on your research----Do you think this is related to the motor actuator??
 

·
Registered
Joined
·
17 Posts
I was only getting air through the vents at your face, I couldn't defog the windshield - and I didn't know it but the automatic temperature compensation feature wasn't working either. I removed the control panel and found that a clip had come loose from the back. Probably when the P.O. replaced the stereo. I replaced the panel because I had bought a used one and it's working fine now.
 

·
Registered
Joined
·
841 Posts
It is mentioned that all the actuators HVAC are behind the glove box toward the center console. Since I think my problem (see above) is the flap or motor, or actuator (for the heat center face level) is all this accessible from behind the glove compartment box (as abrcrombtg indicates). Is the fuse box in the way to get to this?
 
1 - 10 of 10 Posts
Top