BMW E46 Fanatics Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
505 Posts
Discussion Starter #1
Hey all,

This would be my first post on these forums, happy to be joining the community. I drive an '04 325 with 100,xxx miles on it. After installing a cold air intake, suddenly my car has this terrible whistling noise on acceleration. The pitch of the noise varies with my throttle, and is most obnoxious around 3k RPM.

What I've done so far to try and fix the problem:

- Replaced lower intake boot (Elbow tube, connects directly to throttle body)
- Checked throughout the intake system for leaks with compressed air -- no leaks at all
- Thoroughly inspected upper intake boot, along with all of the connections between the intake tubes -- everything is totally solid

Also to note:
- I'm assuming this is connected to this issue; my windshield wiper fluid is not pressurized (this happened immediately with the whistling noise) i.e. it doesn't spray up on the windshield, it just flows out of the jets.

If anyone has ANY ideas on what could be causing this, it'd be greatly appreciated. Again, happy to be joining the community. Cheers!
 

·
Registered
Joined
·
3,424 Posts
Trust me it's the cold air intake. How do I know? Changed everything from pulley to belts to alternator chasing that sound. Although all those parts were due to be changed anyways especially alternator, put the old one back in and you'll know I'm right
 

·
Registered
Joined
·
7 Posts
I had a whistle noise after my afe intake install. Was waiting for a light to pop up but never did. I still get the whistle, it's been about 2 weeks but It doesn't bother me

Sent from BimmerApp mobile app
 

·
Registered
Joined
·
17 Posts
I've had the same whistle on acceleration. Changed the boots, CCF/oil catch/ dipstick tube with no luck. I have a K/N intake and yes I noticed the whistle after install, but I also tried reinstalling the stock box to get rid of it. I still heard the whistle with the stock box. The thing I want to try is a smoke test, but I don't know anyone with one to see if it is a air leak or if it is something unrelated to the vacuum of the car.

I also get a air release sound a second or two after the car is shut off, no codes popping up either.
 
1 - 6 of 6 Posts
Top