BMW E46 Fanatics Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
3,906 Posts
Discussion Starter #1 (Edited)
i am having a problem with my blown (centri) 330, it could possibly just be a dirty filter but heres my problem and heres what i think will fix it. i am looking for a 2nd opinion from anyone who has experienced this problem and successfully fixed it

problem- my car doesnt run in the rain, or even in extremely high humidity days. it bogs down and limps out flashing a cel and fixing it self when the car is reset.

hypothesis- the humidity in the air is stealing all the oxygen content out of it and making me not have enough 02 to combust all the fuel im dumping into the cylinders.

- i am currently using "asatronic" which is essentially a variable resistor in the maf line to the ecu. (correct me if wrong on any of this) therefore the car reads how much o2 its getting, and the low signal due to high humidity is not compensated by the asatronic, which is still dumping the normal (but atm too much) fuel.

resolution - purchase software which is "smarter" and will act accordingly to balance the fuel to oxygen ratio, instead of just fuel to the mass of (wet) air thats entering the system

any advice would be amazing before i go ripping stuff apart and spending money.
-RR

edit: or would the heating of the compressed air evaporate the water in it, and this problem is something else entirely?1?
 

·
Registered
Joined
·
3,906 Posts
Discussion Starter #2
20 views an no ones heard of this beforE? am i that redtarded?

does what im saying make sense or am i barking up the wrong tree? have any facts mixed up? am i imagining how the MAF works incorrectly? anything?
 

·
Registered
Joined
·
3,906 Posts
Discussion Starter #4
Your hypothesis sounds like a pretty big leap to me. Have you checked to see what codes are being thrown?
no i have not, and im sure i should, but i have felt my car bog out because it was too rich before, and im 75% sure thats whats happening

as i said the cel never stays more than a moment im not sure if the codes remain

(p.s. i have tested this many times, it ONLY happens in the rain or very wet air, and it only happens under large boost (max load))

thanks for your thoughts, at the very least they have me rechecking myself
 

·
www.my330i.com
Joined
·
1,912 Posts
The ASAtronic only scales the MAF readings to adjust for larger injectors. That's about it. The MAF should still be able to read through air mass changes, aka humidity, temp, etc.

I would still recommend full software so the engine is indeed being run correctly from the MAF to injection, to timing, to VANOS. But that may not be what is your exact problem.

Have you cleaned the MAF recently? Infinitas kits are known for blowing crankcase oil back on the MAF.
 

·
Registered
Joined
·
3,906 Posts
Discussion Starter #6
The ASAtronic only scales the MAF readings to adjust for larger injectors. That's about it. The MAF should still be able to read through air mass changes, aka humidity, temp, etc.

I would still recommend full software so the engine is indeed being run correctly from the MAF to injection, to timing, to VANOS. But that may not be what is your exact problem.

Have you cleaned the MAF recently? Infinitas kits are known for blowing crankcase oil back on the MAF.
ah, i knew someone would come with an obvious check i forgot. thanks will check it out
 

·
Registered
Joined
·
3,906 Posts
Discussion Starter #8
clean your maf first and let us know?

are your cel ever come out exhaust cam sensor or intake cam sensor?? i had a stalling problem with my NA setup whenever it rained or humid out and it was my exhause cam sensor and i replaced it both.problem fixed
hey thanks alot for this addition, another thing to check. the car is at home im at school atm. also the 540 just got out of the shop so its time to go back and check it out soon ill post back when i nail the problem
 
1 - 8 of 8 Posts
Top