E46 Fanatics Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 · (Edited)
So CEL is on, throwing p0430 and p0456. The p0430 is most likely a exhaust leak I have with a bad manifold gasket on cyl 4-6 (New ones are just waiting to be put on this fun-filled weekend, got the penetrating oil ready), but the p0456 is a real ass. Replaced the gas cap because it was the easiest thing to do, but no good. I took it over to a buddy that has a pressured smoke tester, and we tested both lines at the EVAP purge valve (EVAP purge valve tested fine, but should it be changed at 90k?). When we tested the line to the back of the car, we found a huge leak coming from the passenger rear fender. Looking on realoem it was coming out of the vent hose for the dust filter. We also tested the other line of the valve, and there was a decent leak at the DISA valve, on the bottom out of the o-ring. With the DISA out I saw that the o-ring was trashed, so I bought the GAS kit since the DISA was still working otherwise. Also, covering the hole and smoke testing again confirmed it was the DISA that was leaking.

So my questions are 1) Should the dust filter vent hose be blowing smoke while the car is off, or at all and 2) Is there a chance that the leaking DISA is throwing the p0456?

I know that the DISA is not EVAP but after plugging the dust filter vent hose, we could not see any smoke anywhere. We looked at the lines in the engine, under the car, we took the back seat out to check the fuel pump, we took off the plastics covers on everything around and under the passenger rear tire and we couldn't see anything else.

Thanks in advance,
Wladek.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #2 ·
Just an update:

Over the weekend I rebuilt the DISA valve and fixed the leak there. I also put in new gaskets it exhausts for the cat code. Doing another smoke test still showed no leaks other than the dust filler vent tube. Just like before we covered it up and search the car over again for leaks. Driving the next day I got a P0456 pending. I tried finding information online about the dust filter vent hose but couldn't get anything. Can anyone weigh in on this? Do I need a new dust filter or ldp? Can this be what's throwing the P0456?

-Wadek
 
1 - 4 of 4 Posts
Top