E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 8 of 8 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Hello there!
I have a 330Xi (auto gearbox) with the famous vibration problem. I read multiple threads about this phenomenon and possible solutions but nothing helped. The following things has been replaced: oil in transmission, oil in rear diff, the whole CCV system, spark plugs, the DISA valve, front CV axles, transfer case bushing, motor mount, VANOS seals.
I don't have any fault codes. The vibration occurs in Drive and Reverse it disappears in Neutral and Park. It also disappears if the car starts to move. The RPM is relatively stable 650 in drive, a bit higher in park. Also when is shift the RPM drops to 500 for a second. The problem is equally bad in hot and cold temps. Where should i search for the problem, what other components could be bad? Any help is highly appreciated! :cry:
 

·
Registered
Joined
·
23 Posts
Vibration check the door skins

I slide ripped up business cards and matchbooks into the space between the door and skin as I found it vibrates if not tight Sorry about the skin terminology idk what it's called but when you replace window regulators a few time the little plastic clips can break

Good Luck
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #5 ·
I slide ripped up business cards and matchbooks into the space between the door and skin as I found it vibrates if not tight Sorry about the skin terminology idk what it's called but when you replace window regulators a few time the little plastic clips can break



Good Luck


Do you mean the door panel? I will check that out, but this vibration is really strong and certainly feels like some mechanical issue.


Sent from my iPhone using E46Fanatics mobile app
 

·
Registered
Joined
·
49 Posts
Mine has gotten worse over the years. I was able to trace some of it to loose exhaust shielding. This solved the annoyance but doesn't explain why it vibrates in the first place. I have not solved that.
 
1 - 8 of 8 Posts
Top