E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 17 of 17 Posts

·
Registered
Joined
·
132 Posts
Discussion Starter · #1 ·
Few days ago warning light for my left signal light started coming on.
Weird thing is that it'd turn on for a while, turn off, and come back on again.
Dealer told me that it's the aftermarket silver bulbs causing the problem and replaced both fronts with yellow bulbs but the light came on again as I was driving home from the dealer.
Anyone else have similar experience?
Oh by the way I got my airbag warning light fixed for 5th time. They replaced the wires to controll unit. I hope that fixes the problem for good
 

·
Registered
Joined
·
202 Posts
same thing happend to me with the turn signal off and on for a few days, then eventaully it just burned out completely, replace it now its fine
 

·
Registered
Joined
·
10,806 Posts
had the same problem, just play around with the bulb, thats what i did, fixed it, and never had it again. dealer also gave me the same BS excuse
 

·
Registered
Joined
·
705 Posts
yes. tell you what you need to do. It just happens to do this on the 1999s and 2000 cars when you replace the stock bulbs. It doesn't madder what kind you use or not. It’s when you take the bulbs out the connecting starts to go bad. My left side did the same thing.

go to BMW and buy the new bulb socket. I think I paid 3.70 for ea. That’s the black part the bulb plugs into. They changed it in late 2001 I think.
 

·
Registered
Joined
·
705 Posts
this is the old one. Another problem was that sometimes when you replaced bulbs with aftermarket ones the pins were slightly off set. So ones you got the bulbs in there you couldn't get them out. :thumbdwn:

lucky for you BMW normally stocks this part. Just ask them and they can get you one right there.
 

Attachments

·
Registered
Joined
·
287 Posts
TimeFor said:
this is the old one. Another problem was that sometimes when you replaced bulbs with aftermarket ones the pins were slightly off set. So ones you got the bulbs in there you couldn't get them out. :thumbdwn:

lucky for you BMW normally stocks this part. Just ask them and they can get you one right there.
yeah if u put the aftermkt bulbs in yur screwed...BUT if u take wire cutter and chop off one of the prongs yur good to go..if yur warning light comes on but the bulb is still good just remove it and pry on the metal connector piece with a screwdriver...pry it up so it makes full contact with the bulb..youll prolly notice the metal on the bottom of the bulb is starting to melt, thats whats causing the problem:thumbup:
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #10 ·
You know what...they took my silvervisions and put in OEM ones. the bastards. I bet one of them's got them in their car now. when I got back, I bought fresh pair and put them in and it was okay when I was driving home. I'll have to wait and see.
TimeFor....thanks for the info. I'll try that next if they give me problems. Question tho. don't these come with OEM clears?
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #11 ·
Still same problem. I guess I'll try replacing the socket. I just pray it's not some electrical problem with the car.
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #12 ·
go to BMW and buy the new bulb socket. I think I paid 3.70 for ea. That’s the black part the bulb plugs into. They changed it in late 2001 I think. [/B][/QUOTE]

Okay, so I went to Pacific BMW and they said they had two different types. 99-00 ones are black and are 8 bucks each.
01 one is white and cost 15 bucks each. The guy there claims that 01 plug will not fit 99 model cars. I'm confused.
well I figured if it costs 30 bucks to replace them, I might get front clears since they come with it. They're like 90 bucks right?
I dunno. suggestions?
 

·
Registered
Joined
·
287 Posts
AC schiznitzer said:
go to BMW and buy the new bulb socket. I think I paid 3.70 for ea. That’s the black part the bulb plugs into. They changed it in late 2001 I think.
Okay, so I went to Pacific BMW and they said they had two different types. 99-00 ones are black and are 8 bucks each.
01 one is white and cost 15 bucks each. The guy there claims that 01 plug will not fit 99 model cars. I'm confused.
well I figured if it costs 30 bucks to replace them, I might get front clears since they come with it. They're like 90 bucks right?
I dunno. suggestions? [/B][/QUOTE]

when i had a 330ci i got black ones from BMW ..it was 2001 model
 

·
OG Moderator Extraordinaire
Joined
·
5,358 Posts
AC schiznitzer said:
Okay, so I went to Pacific BMW and they said they had two different types. 99-00 ones are black and are 8 bucks each.
01 one is white and cost 15 bucks each. The guy there claims that 01 plug will not fit 99 model cars. I'm confused.
well I figured if it costs 30 bucks to replace them, I might get front clears since they come with it. They're like 90 bucks right?
I dunno. suggestions?

I have a 2000 323Ci. This has happened to me with both corners now. I've replaced both myself. I'm not sure if it was the plug or the bulbs, but I've used the black and the white plugs. The white plugs haven't given me a problem at all... both black ones wouldn't work.

I took the bulbs out of the plugs, and I noticed some weird metallic foam like build-up on the end of the bulbs (where it connects to the metal piece in the plug). I cleaned that off, and put the bulb and plug back in and it worked for a while, then the light came on again. I swapped out the black plug for the white and haven't had a problem in a few months :thumbup:


oh yeah, and I think the white and black plugs were different, because the bulbs fit differently (e.g. I couldn't put the bulbs from the black plugs into the white plugs, and vice-versa.). But both plugs fit into the light housing and the cable attached fine...
 

·
Registered
Joined
·
132 Posts
Discussion Starter · #15 ·
Thanks everyone. I figured it it out. you guys were right, it was the bulb socket.
Yesterday I swaped the left and right bulb sockets and sure enough, the right side warning light came on(It was the left one before) Now that I've pinpointed the problem, I just gotta buy a new socket.
Thanks again guys.
 

·
OG Moderator Extraordinaire
Joined
·
5,358 Posts
AC schiznitzer said:
Thanks everyone. I figured it it out. you guys were right, it was the bulb socket.
Yesterday I swaped the left and right bulb sockets and sure enough, the right side warning light came on(It was the left one before) Now that I've pinpointed the problem, I just gotta buy a new socket.
Thanks again guys.

and try and get your silver bulbs back!!!



stupid dealers :banghead:
 

·
Registered
Joined
·
27 Posts
Hey guys..

I had the same problem.. I have a 2000 323i and so does my sister and we both started to get the light indicator light to come on, so I took it to the dealer and my service rep said it was covered under warranty and there where a couple of other cars there getting the same thing done ... they changed my socket and he did it wile I waited not long at all...
Moritz BMW Arlington TX.
 
1 - 17 of 17 Posts
Top