E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
After driving for 30-45 minutes or so my car jerks and the transmission malfunction light turns on putting my car into the "safe mode." Also while driving in the automatic D mode the car jerks when shifting into the second gear. So far I have had an oil change, transmissions fluid change and had 2 solenoids replaced (suggested by AAMCO) but yet the problem still occurs. The car is a 2001 330xi. Any ideas what the problem could be?:cry::cry::cry::cry:
 

·
Registered
Joined
·
0 Posts
Looks like ur tranny could be going out, but this problem is usually on the 323s and 325s if u have a peake scanner check it for codes if not then have it diagnosed...
 

·
Registered
Joined
·
2 Posts
I have the same problem with mine.

Ran my codes and got

50 Gear check 1
55 Gear check 5
And safe mode code

So far i think its the trans is shot.

Mine only falls into limp mode when i go faster than 65 mph or over 2500RPM
 

·
Registered
Joined
·
1,367 Posts
Don't you guys ever do a search function? The safe mode is normally not repeat NOT a problem with the transmission. It is normally associated with fluctuations in voltage. Have your battery and alternator checked out by someone competent.
 

·
Registered
Joined
·
4 Posts
a friend and i r having a problem with a 1999 bmw 323i automatic tranny not movin in any gear not slippin just not movin in any gear at all, it will manually go in all the gears at a stand still, but it wont move at all he had a bad battery in it we replaced it after the car wouldnt move figuring it would help but nope its still the same do u think the tranny might b bad or is it in some safe mode the codes r p0101 and p1707 do not have a peake scanner.. anyone have any idea what it might b
 

·
Registered
Joined
·
2 Posts
Since then i changed my transmission fluid.
Made it noticeably better but still locking into safe mode.

Transmission died 1000 Miles after fluid change (my fluid was dark- change your fluid before its to late!)

New trans was the only repair.








I have the same problem with mine.

Ran my codes and got

50 Gear check 1
55 Gear check 5
And safe mode code

So far i think its the trans is shot.

Mine only falls into limp mode when i go faster than 65 mph or over 2500RPM
 
1 - 7 of 7 Posts
Top