E46 Fanatics Forum banner
1 - 4 of 4 Posts

· Registered
2002 325i auto
Joined
·
14 Posts
Discussion Starter · #1 ·
Hello everyone!

I have a 2001 330i automatic which currently has 280k miles. Trying to reach 300k which I think all m54 engines could do. Recently when driving on the freeway I noticed it starting to slip. It has no codes on the dash and not even the cog light next to the gear. It drives just fine but it does slip at higher speeds. I decided to scan it using pa soft and it gives me this error. Any way to solve this issue? Can you just replace the torque converter rather than the transmission? If this transmission is failing it might be the end of this e46 life as a rebuild would cost more than the car itself which is not worth it. Thankyou for even reading this.
Output device Wood Rectangle Mesh Font
 

· Registered
2002 325i auto
Joined
·
14 Posts
Discussion Starter · #5 ·
The torque converter does not last forever, so that is where I would look first. Reman TCs are not that expensive, though the job is a pain.

As Bali said it could be the solenoid or the upper front valve body where the piston that controls TC lockup is.

It could also be low pump pressure. Is the fluid original? Are you sure it is not low?
Thanks, is it separate than the transmission itself? I don’t need to reapply a seal or anything right just the tc? I replaced the filter and the fluid last year , might have to check again.
 

· Registered
2002 325i auto
Joined
·
14 Posts
Discussion Starter · #9 ·
FYI to all, the TCC has variable lock-up via PWM control. The EGS measures the amount of TCC slip via the various speed sensors and throws a code when it is not within the expected range it commanded.
Is mine not severe enough for it to not even show any codes until you scan it with pa soft?
 

· Registered
2002 325i auto
Joined
·
14 Posts
Discussion Starter · #11 ·
What? I do not understand what you are saying.
The fault codes are there whether you read them with BMW Scanner 1.4 (PA Soft was the company, not the product), INPA, Carly, or whatever.
Like there is no code on the dash or the cog light telling me something was wrong. I only knew about the code after looking at the bmw scanner 1.4. I feel like there should of been Atleast a code on the dash or something.
 
1 - 4 of 4 Posts
Top