BMW E46 Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
My top opens and closes only by using the key in the door lock. The buttons don't do anything. They don't have any lights either.

Does anybody have an idea what the problem could be?

Thanks.
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
Could be, but they just stopped all of a sudden. No spillage. Yes, the car has 220,000 miles on it and I am grateful the top still works. I should count my blessings.
 

·
Registered
Joined
·
2,755 Posts
Could be, but they just stopped all of a sudden. No spillage. Yes, the car has 220,000 miles on it and I am grateful the top still works. I should count my blessings.
I'd replace the button assembly myself.
 

·
Registered
Joined
·
65 Posts
Check a post from April by Cwolfey. He has a list of fuses that he replaced to get a problem like yours resolved.

El Barto
 

·
Registered
Joined
·
61 Posts
Discussion Starter #7
Well I found that post and sure enough, I did not have a fuse in #6. I put one of the spare 5v fuses and whamo! The buttons worked. That makes me wonder if that fuse fell out or what.

Thanks a lot!
 

·
Registered
Joined
·
65 Posts
No problem. Glad to hear all worked out! The real thanks go to Cwolfey for getting back to the site once he Had the resolution. That doesn’t always happen, and I am glad you paid it forward by documenting your solution.:thumbup:
 

·
Registered
Joined
·
8 Posts
Worked for me too!

I had the same exact problem. It turns out the fuse from #6 had gotten moved to #5 by mistake. Placed it back in #6 and everything works just like it should. Thanks for the fix!
 
1 - 10 of 10 Posts
Top