E46 Fanatics Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter · #1 · (Edited)
My top was acting strange, it was only wanting to go up halfway. This was a sudden problem on the way to work, flawless operation prior to this.

I had read that others with this problem had fluid and pump issues, but mine looked fine, fluid level was fine, color and consistency looked fine.

I had also read about others replacing the harness that runs the length of the top's frame, from front to the back of it. I inspected it visually and can see why the wiring can fail, it is tucked up close to the frame, and folds with it when the top goes up and down.

I striped back the black webbed cover over the harness at the first fold, and found a broken wire. The wire that failed was a green with white stripe. It broke in two, a few others looked as if they may fail in the future, but not broken, yet.


Uploaded with ImageShack.us




Uploaded with ImageShack.us


I broke out the soldering iron, heat shrink, and a bit of extra wire and replaced the broken section. The top now operates as it should, plus it saved me a trip to the dealer.

I already had solder, soldering iron, several different gauges of wire, and heat shrink, so total cost to fix was $0.

If I have wiring problems again with this harness, I will just pony up the $200 for a new wiring harness and replace it myself. Seems fairly straight forward, just unscrew a bunch of clips and replace the harness. For now, it didnt cost me a dime, just a couple hours this evening.
 

·
Registered
Joined
·
2,575 Posts
Thanks for posting. I've had my eye on this wire bundle and may have to fix mine soon.

I'm also wondering if that gas strut shown in your first pic could be the reason my top frame slams down in the front when closing. I'll remove it this Sunday and try to see if it seems weak.
 

·
Registered
Joined
·
690 Posts
Excellent post. I had very similar issue when I first bought the car. Unfortunately my wiring flaw was not so clearly defined and required dealer diagnosis. 4 hours later they found it but only charged for 1 hour labor plus harness.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top