E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!
1 - 3 of 3 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter · #1 ·
My heater is only blowign cold air and my temp guage moves into the red after a short drive. Recently thought overflow tank was leaking but ended up being a lose hose connection at the bottom near the bleed screw...

Any thoughts? The temp gauge will actually fluctuate a lot, I'm thinking thermostat is stuck closed (I know they typically stick open though)

Did the leak cause sensors to fry? Air in system?
 

·
Registered
2016 340i xD 6-spd
Joined
·
26,980 Posts
My heater is only blowign cold air and my temp guage moves into the red after a short drive. Recently thought overflow tank was leaking but ended up being a lose hose connection at the bottom near the bleed screw...

Any thoughts? The temp gauge will actually fluctuate a lot, I'm thinking thermostat is stuck closed (I know they typically stick open though)

Did the leak cause sensors to fry? Air in system?
Fluctuating temp gauge? That sounds like air in system. Read around 27-30 cooling threads just so you find the right way to bleed...be careful, there are many who think they know how but more that have messed up just this one step. Read a lot.

You opened her up to fix that hose? I'm assuming that was just immediately prior to these symptoms. If not...it could be therm closed...they do fail that way also.
 

·
Registered
Joined
·
28 Posts
Discussion Starter · #3 ·
air in system

Thanks DMAX,

Yeah, the system was opened up as part of my overall inspection fo the sytem I first thought tstat was shot, then saw the leak and though the tank was shot, then saw the hose connection issue (probably from the guy that replaced my radiator.... should have done myself).

I'll read on how to bleed system.... thanks..
 
1 - 3 of 3 Posts
Top