E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 20 of 24 Posts

·
Registered
Joined
·
1,913 Posts
Discussion Starter · #1 ·
Well, it's FINALLY installed after waiting two months....It was waiting for me outside the install shop. It started right up, but it sounded like a screaming cat under the hood :eek:. I shut it down, opened the hood and as far as I can tell everything looked ok....Maybe it's supposed to give a little whine???

So I left the lot got about a quarter mile down the road and felt it just WASN'T right, there was WAY too much noise....so I turned around and left my car there and left a message on their voicemail telling them I didn't think the noise was normal of what a supercharger sounds like...Is the Vortech really this loud??? Pics and a short video below:

HELP!
The video is at the bottom below the pics of belt and blower

Thanks,
Chip-
 

·
I got nothin'
Joined
·
283 Posts
Maybe that screaming noise was you screaming like a beyotch because it is too much power for ya? :):lmao: :lmao:
 

·
Registered
Joined
·
1,940 Posts
No an SC should not scream like that, especially at idle. Sounds like something didn't have proper lubrication for some reason.
 

·
Yes...I do think I hate you
Joined
·
1,539 Posts
what kit is it. the old vortec kits made a lot of noise...but the new ones are supposed to be more stealth. ?
 

·
TheOnlyConstantIsChange
Joined
·
4,180 Posts
I got it just before it started jumping around :thumbup:
 

·
Registered
Joined
·
1,913 Posts
Discussion Starter · #10 ·
It's the Vortech SQ which I thought meant Super Quiet :confused:
 

·
I've got what plants crave.
Joined
·
1,360 Posts
you are an

A S S H O L E

ha ha ha ha ha

:flipoff:
:flipoff:
:flipoff:
:flipoff:
:flipoff:
:flipoff:
 

·
Registered
Joined
·
504 Posts
How about I try to give you a real answer for a change.

Check and make sure that the belt tension is up to the spec (of the SC manufacter) and that the belt is installed correctly on the pulleys.
Its the tension most likely.
If not, try to pin point the noise, if its coming from the SC unit then you just might have a "bad one". :sad:

Can I drive the car sometime? :tongue:
 

·
hammer talks like this
Joined
·
3,967 Posts
wheres that post comparing his hair with jim carry's, when u need it??? "you are a coc k sucker ha ha haaaaaaaaaa"
 

·
Registered
Joined
·
1,011 Posts
It took the shop 2 months to install it? Is that what you're saying? Where did you get it installed? They dont sound like they know what they're doing, if they give it to you making noise like that (or if it took 2 months to get it installed).
 

·
I've got what plants crave.
Joined
·
1,360 Posts
I can't believe this got moved to the Gen. Forum. AHAHAHAHAHAHAHAHAHAH

OMFG :lmao:
 

·
Registered
Joined
·
1,940 Posts
ScottV said:
It took the shop 2 months to install it? Is that what you're saying? Where did you get it installed? They dont sound like they know what they're doing, if they give it to you making noise like that (or if it took 2 months to get it installed).
I totally agree with that one. Hope u only paid them for 16 hrs of labor.
 

·
Registered
Joined
·
1,913 Posts
Discussion Starter · #19 ·
I can't believe this got moved to the Gen. Forum. AHAHAHAHAHAHAHAHAHAH

OMFG
mc, I think the whole world has gone mad....lolol.

The install takes about 3 days of off an on, I couldn't get a shop to do it for 2 months.

I'm still waiting for the ECU to be shipped back from the UK, the car hasn't even fired up yet...this post was an attempt at April Fools humor...:lmao:

Kamil, just come to some meets this year, it will be there :)

bender...why I aughta....:tongue:
Chip-
 
1 - 20 of 24 Posts
Top