BMW E46 Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
110 Posts
Discussion Starter #1
So I recently set up a very "budget" drift car. It is a 325ci I bought for $400.
Had a drift event about a month ago and car drove great for about 3 hours, until the center support bearing broke.
I replaced it, and at the last event two weeks ago it ran good for about an hour, got a little hot (just a little past half way but before 3/4).
I let it cool down and started driving again and it did well for about another 10min. After that it began bogging down under hard acceleration in low rpm. For example, I could floor it and have power if it was over 4k rpm, but to go from idle to 4k i would have to slowly give it more gas over about 7-10 seconds until it reached 4k. any more than a quarter throttle under 4k and absolutely no power. I am thinking vacuum leak but wanted some other opinions of what it could be?
Thanks!
 

·
Registered
1999 bmw 328i
Joined
·
87 Posts
Possible it could be your vanos seals ive read and experienced in my own car that when they are going bad you can lose low end torque but if you rev up to 3500-4000 the power comes on better i met a guy the other day who told me his seal actually came apart and it made the car have no low end power at all

Sent from my LM-Q730 using Tapatalk
 

·
Registered
Joined
·
110 Posts
Discussion Starter #3
Possible it could be your vanos seals ive read and experienced in my own car that when they are going bad you can lose low end torque but if you rev up to 3500-4000 the power comes on better i met a guy the other day who told me his seal actually came apart and it made the car have no low end power at all

Sent from my LM-Q730 using Tapatalk

I forgot to mention it’s intermittent. Drove good for 20min then no power issue. Didn’t drive for about 15min and back to normal. Then 10 min later happens again. So it’s not at all times. Usually after 10-15 min of driving.
 

·
Registered
1999 BMW 323i m52tub28 swap
Joined
·
3 Posts
Have you pulled the spark plugs to see what they look like? I'd start there, then check for vacuum leaks, any check engine light?
 
1 - 4 of 4 Posts
Top