BMW E46 Fanatics Forum banner

1 - 10 of 10 Posts

·
Track it
Joined
·
930 Posts
Discussion Starter #1
I jumped in the car and let it roll out of the garage this morning, as its on a slight incline. I started her up gently and let the oil pump up to the heads so she had a few minutes to wake up, and after like 30 seconds the ***** starts misfiring...! Sounds like one of the injectors was clogged, or a coil was bad or something. I brought it to BMW of Bayside in Queens.....they took it and rented me a Galant...the guy from enterprise was like..."its not a BMW but it coulda been alot worse!"...In my head I though actually....:puke: .....no it couldn't. Im just happy I got a car not a handshake. Anyway......they told me they'd contact me when they knew what was the matter and when it would be ready but I got a Galant for the first snowstorm we're gonna have in NY this winter...save my baby from all the salt n crap for now anyway and I'll get to do some donuts, backwards. I never am particularly pleased by the way I get treated at BMW of Bayside but this time was a great experience. I met with service advisor Tom Douda who also happens to be a Manchester United fan and he with the utmost respect and took care of me immediately...walked around the car...all that jazz and enterprise dropped off a Galantathon for me in about 15 minutes... I wish it was auto-x season so I could see whats its got.....

Anyways just wanted to let you guys know about the positive experience and since I always b1tch about BMW of Bayside, I thought I'd compliment them when deserved...:thumbup:
 

·
Banned
Joined
·
730 Posts
Yeah, my car did that too. Found out it was 2 ruined cylinders, 12 bent valves and a blown head gasket.


(So they say). Doesn't seem to look like it at all.
 

·
Track it
Joined
·
930 Posts
Discussion Starter #3
Whaaaat! I did drive the **** out of the car last night...but nothing along the lines of bent valves...when I put her to bed everything was cool.....
 

·
Registered
Joined
·
353 Posts
Have you heard a\t from the dealer
 

·
Track it
Joined
·
930 Posts
Discussion Starter #6
No word from the dealer yet....they said they were prety busy though and I dropped it off at 1.00pm this afternoon....the car only has 15k miles, I didn't expect for something like this to happen...probably because i treat it too good...
 

·
Registered
Joined
·
184 Posts
When my car misfired and ran badly last year, it was two of the coils... Problem was intermittent... Did your car throw any flags?
 

·
Track it
Joined
·
930 Posts
Discussion Starter #10
Guys...i haven't been able to post...I got the car back the same day, about 3 hours after i dropped it off. Turns out is was a bad coil just as you suggested. #5 was replaced and everything is good as new. It was weird when I dropped it off. The advisor suggested it might be a coil. He said he had written up the same type of car with the exact same mileage for the same problem earlier that day and thats what it turned out to be....
Anyway, I was pleased everything was resolved so quickly and painlessly...I got my car back quick with no damage.... Still makes me kinda pissed that a coil would just go bad out of the blue like that....

There were no flags when happened except the service engine soon light which came on after about 3 minutes.
 
1 - 10 of 10 Posts
Top