E46 Fanatics Forum banner
1 - 17 of 17 Posts

·
Registered
Joined
·
64 Posts
Discussion Starter · #1 ·
Searched around a few different sites and forums, but haven't found an exact replica of my issue. Based on what I have found though, I know that it will be difficult to self diagnose the issue, So I want to get a list of potential issues to bring to my mechanic for investigation.

During acceleration from standstill, I get a quick shudder/vibration/shake in what feels like the rear passenger wheel well area. It usually happens around 2500 rpm under steady but not excessive acceleration (think 60% pedal push). Sometimes it only happens once when going from 1st to 2nd, sometimes it will happen again in 2nd to 3rd, but never 3rd to 4th or higher.

The feeling is akin to driving over a rumble strip, and is only there for literally 1 second. Maybe 4/5 "thumps" before it stops, never more. The whole car doesn't shake, it's not strong enough to feel when the music is on, but if you try to feel/hear it, it's there.

I have an automatic transmission btw. figure that might matter since it seems to be during shifts. Tested sport mode and it still happens up to 3000 rpm, but always in low gears.
 

·
Registered
2004 330CI 6spd
Joined
·
588 Posts
95% sure it's the centre support bearing.

The rumble will only get worse and more often under less load. If left unattended, the drive shaft may become warped.

Cheers; E46Envyy
 

·
Registered
Joined
·
332 Posts
Hmm, i get this too, only in 1st or 2nd gear (maybe 2nd & 3rd, can***8217;t exactly remember), around 25 mph. It***8217;s louder if I push the car harder, but the noise goes away after that 25-30mph. Auto as well.

Would love to hear your results of what fixed it
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #7 ·
So after a few weeks, I***8217;ve finally gotten the drive shaft off at a shop. The CSB is broken but the front and rear u joints are also locked up. Whether that***8217;s from the failed CSB or was an issue that cause the failed CSB, we don***8217;t know. Even smacking the joints with a rubber hammer couldn***8217;t loosen them.
 

·
Registered
2004 330CI 6spd
Joined
·
588 Posts
So after a few weeks, I***8217;ve finally gotten the drive shaft off at a shop. The CSB is broken but the front and rear u joints are also locked up. Whether that***8217;s from the failed CSB or was an issue that cause the failed CSB, we don***8217;t know. Even smacking the joints with a rubber hammer couldn***8217;t loosen them.

At least you’ve found the issue. The u-joint probably caused the failure. My bro drove around with a failed CSB and when we finally changed it the u-joint was super lose and sloppy. That ds was toast!

P.S – if your doing the CSB remember to pre-load a couple mm forward.

Cheers; E46Envyy


Sent from my iPhone using E46Fanatics mobile app
 

·
Registered
Joined
·
332 Posts
Have had this EXACT same problem, and finally ordered a guibo & CSB to replace it tomorrow.

Highly crossing my fingers that I haven't ruined the driveshaft in the process here too, but we'll see - Car has 84k on it, and was like it when I got it 4k miles ago.

Honestly fairly surprised that at 84k the driveshaft has issues, but yeah... Really hoping my U-joints are OK and it's just the CSB / Guibo.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #12 · (Edited)
Good luck, hopefully you come out more unscathed than I did. The strangest thing is that except for the noise, the car drove fine. Once I got into third there were no issues, which made me want to just keep using the same shaft and replace the CSB and guibo. But it's not advised I'm told.

Have had this EXACT same problem, and finally ordered a guibo & CSB to replace it tomorrow.

Highly crossing my fingers that I haven't ruined the driveshaft in the process here too, but we'll see - Car has 84k on it, and was like it when I got it 4k miles ago.

Honestly fairly surprised that at 84k the driveshaft has issues, but yeah... Really hoping my U-joints are OK and it's just the CSB / Guibo.
 

·
Registered
Joined
·
332 Posts
Good luck, hopefully you come out more unscathed than I did. The strangest thing is that except for the noise, the car drove fine. Once I got into third there were no issues, which made me want to just keep using the same shaft and replace the CSB and guibo. But it's not advised I'm told.
It was hard as hell, haha. The damn exhaust was the hardest part - the bolts that connected the manifold to the rest of the exhaust were 100 percent fused to themselves...

Replaced the CSB & Guibo and can't tell if it fixed the problem or not. Didn't REALLY see much play in the U-joints, so i couldn't totally tell if they were bad either.
 

·
Registered
Joined
·
64 Posts
Discussion Starter · #14 ·
Got the car back today. Examined the old drive shaft and it turns out that to only the u-joint connected to the flex disk was immobile. Also the old flex disk was in fairly good condition, more flex than a new one but no cracking or threading visible. Replaced it anyway. So the main failures were the CSB and the front U Joint.

Good luck, hopefully you come out more unscathed than I did. The strangest thing is that except for the noise, the car drove fine. Once I got into third there were no issues, which made me want to just keep using the same shaft and replace the CSB and guibo. But it's not advised I'm told.
It was hard as hell, haha. The damn exhaust was the hardest part - the bolts that connected the manifold to the rest of the exhaust were 100 percent fused to themselves...

Replaced the CSB & Guibo and can't tell if it fixed the problem or not. Didn't REALLY see much play in the U-joints, so i couldn't totally tell if they were bad either.
 

·
Registered
Joined
·
332 Posts
Got the car back today. Examined the old drive shaft and it turns out that to only the u-joint connected to the flex disk was immobile. Also the old flex disk was in fairly good condition, more flex than a new one but no cracking or threading visible. Replaced it anyway. So the main failures were the CSB and the front U Joint.

Good luck, hopefully you come out more unscathed than I did. The strangest thing is that except for the noise, the car drove fine. Once I got into third there were no issues, which made me want to just keep using the same shaft and replace the CSB and guibo. But it's not advised I'm told.
It was hard as hell, haha. The damn exhaust was the hardest part - the bolts that connected the manifold to the rest of the exhaust were 100 percent fused to themselves...

Replaced the CSB & Guibo and can't tell if it fixed the problem or not. Didn't REALLY see much play in the U-joints, so i couldn't totally tell if they were bad either.
Gotcha, yeah I***8217;m still getting the issue after replacing the flex disc and CSB, both of which were in ok condition, definitely not going. I feel like I felt some play in the rear U joint, so time to order a drive shaft ***x1f615;

Where did you get yours from??
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top