BMW E46 Fanatics Forum banner

1 - 20 of 43 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Alright...so it seems this stalling problem is common, but maybe someone has some more advice. About a month ago, my car started shuttering on start up and feeling as though it was going to stall. Then, the Service Engine light comes on and it actually begins to start stalling every time I would stop at a light or idle (I've heard this might be called "Limp Mode" - who knows) - I should at it would even stall up start up right away. Put the car into the shop (it's been in and out for over a month now), and replaced the MAF Sensor. Spark Plugs, O2 Sensors (Front and Rear), the valve gasket cover (had a slight leak). At first when these things were replaced, the light was off and the car seemed to run fine. Within 24 hours, back to the same problem...

The only codes we were getting were that the car was running both rich and lean at the same time (which I was told was not possible) - switching back and forth between the two. The second code was low fuel...car had a full tank. This code eventually cleared itself out.

Last week, I put the car back into the shop, they couldn't find any other problem and jsut cleaned the injectors (added a fuel additive in to help clean it out). I was told the car was getting an occassional misfire code and this was why they cleaned it up. Picked the car back up 5 days ago, have been driving it and it has seemed to run fine...though that SES light has been going on and off intermiddently. Now...today...back to the shuttering and sure enough...stalling out. I should note, when it drives, its got that sputtering feeling (same as in the very beginning of this problem).

So needless to say...HELP!!!! Any thoughts...comments...ideas (besides dropping this thing into the bay down the block). I've already spent near 2K on this issue.
 

·
Registered
Joined
·
2,613 Posts
does it jerk when cruising?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #4
I should at its a 2001 330ci w/about 150K miles on it (I do a lot of driving).

Green - define jerking? Its got ghtat shuttering/sputtering when it has the problem while I'm driving...almost like you're fighting it to move.

Phrozen - the DISA valve? This isnt something I've heard befor ein relation to this problem...

And guys...forgive me...I'm on semi-knowledgeable about car stuff
 

·
Registered
Joined
·
2,613 Posts
Did you buy the MAF new? Sounds like maybe your egr is stuck open, but you would definitely get a code for that. Some fuel pumps go out also.
 

·
Registered
Joined
·
34 Posts
Discussion Starter #8
Yep...maf, sensors, everything new from a company called bimmerspecialist.com. I actually just went back out to the car, started it...light was still on, but it wasn't shuttering...so its like the car has two personalities haha. If the EGR is stuck open, is there a simple fix? Or does it require replacing and install?

Shop actually checked the fuel pumps also and they said that was fine.
 

·
Registered
Joined
·
2,613 Posts
Yep...maf, sensors, everything new from a company called bimmerspecialist.com. I actually just went back out to the car, started it...light was still on, but it wasn't shuttering...so its like the car has two personalities haha. If the EGR is stuck open, is there a simple fix? Or does it require replacing and install?

Shop actually checked the fuel pumps also and they said that was fine.
There is only one fuel pump. How did they check it? If the light is on what is the code you are getting?
 

·
Registered
Joined
·
34 Posts
Discussion Starter #10
Sorry...the s on pump was a typo. Currently...I'm not sure what the code is as the last thing I was told pertained to a misfire of some sort. I'm going ot try to get over to advanced auto right now to see...will post again in a few. Thanks everyone...btw.
 

·
Registered
Joined
·
7,569 Posts
Check the EGR valve aka DISA valve.
I should at its a 2001 330ci w/about 150K miles on it (I do a lot of driving).

Green - define jerking? Its got ghtat shuttering/sputtering when it has the problem while I'm driving...almost like you're fighting it to move.

Phrozen - the DISA valve? This isnt something I've heard befor ein relation to this problem...

And guys...forgive me...I'm on semi-knowledgeable about car stuff
I had the same problem as you at 155k miles. My mechanic replaced the DISA Valve and the problem went away.

I have 170k miles and mine is also a 2001
 

·
Registered
Joined
·
2,613 Posts
Sorry...the s on pump was a typo. Currently...I'm not sure what the code is as the last thing I was told pertained to a misfire of some sort. I'm going ot try to get over to advanced auto right now to see...will post again in a few. Thanks everyone...btw.
Get the code and go from there.
 

·
Registered
Joined
·
2,613 Posts
Southpaw does.




OP - Find out the code number and let us know from there....
:facepalm::facepalm::facepalm:
 

·
Registered
Joined
·
34 Posts
Discussion Starter #15
Ok..just got the car over to Advanced auto...

Came back with a misfire - low fuel code, 2 lean codes and 2 rich codes. Does this help?

It stalled once when coming to a stop sign on the way over...but drove fine other than that.
 

·
Registered
Joined
·
325 Posts
Check the rubber vacuum line that connects to the fuel regulator on the fuel filter. Could be dry rotted!!!!! Happened to me.

Kevin
 

·
Registered
Joined
·
34 Posts
Discussion Starter #17
Kevin, were you getting codes like that from it?

I believe there was a thorough check on all hoses and lines while they were in there and everything looked good.

Ya know, thinking back, sometime in January, a radiator hose split open, resulting in the spraying of quite a bit of coolant everywhere. I ended up having it replaced (the upper hose) as well as the thermostat (fyi...this was replaced again when the car first went in with the stalling problem). However, when i had that hose replaced (it was a different shop), as soon as I picked up the car and went to drive home, it stalled out on me. When I put it back in there, they claimed they could not find a problem. The real stalling issue didnt show up until April...at which point I started going ot a new shop in Wantagh, NY.
 

·
Registered
Joined
·
7,493 Posts
good lord, buy a peake tool next time instead of a shatload of parts,go from there
 

·
Registered
Joined
·
103,546 Posts
1 - 20 of 43 Posts
Top