E46 Fanatics Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi all,

I have my dearly beloved 1999 E46 328i sedan (M52TU mated to a 5-speed manual) with 82k original miles on it. I always feed it the best of the best, go for checkups 2500 mi in advance, all parts original or quality OEM.

In the last scheduled service, which was roughly a month ago, the VANOS was changed. Other than that, the engine is in tip-top shape - no codes or faults thrown.

Having said that, every once in a while, without any warning, or apparent rhyme or reason, I'll accelerate / almost floor it, and the car will eagerly respond, only to quite drastically engine-brake itself for a split second, then continue as if nothing happened.

Apart from that, the car runs great, but obviously it's not normal for a car to act up the way.

Sometimes the car will act up 2-3 times in a row, within the span of f5 minutes; other times it won't act up for over a month before this issue rears its ugly head again.

I have literally no idea what is going on but I'd like to address it like any other issue I might have with the car, but I don't think it's common (searched the site and didn't find anything related in the forum) and wanted to hear from any of you who might have encountered a similar issue with your car, or can shed light on the issue?
 

·
Premium Member
E30M3 Race F10 535 R1150Rt M Coupe
Joined
·
11,875 Posts
Given what you've described, I would have a look at the ABS/DSC system. Perhaps it thinks the car is slipping or sliding sideways?
Then the traction control reduces the throttle.
 

·
Registered
Joined
·
681 Posts
Check your Intake boot. Those things like to rip. On mine it looked fine until I put eyes on it and pushed on it - then I found that it had torn open. You may have a slight rip that's opening up under hard acceleration. The result is too much air going in past the mass air flow sensor. On my really bad one, it was fine until I accelerated hard enough that it pulled the boot open and started to leak in air.

When ABS/DSC activates, it usually triggers the warning light on the dash. It's possible yours didn't for a quick correction but if it didn't trigger that light I doubt it. There's also an easy test. Turn off traction control and try again. If traction control is off, that system will not trigger. You have to hold the button down to fully disable it each time you drive. (I had just replaced my steering rack and hadn't dialed in the angle yet, so I had to learn that one) Keep in mind that you've just disabled a safety feature when doing this.

Adaptations are the engine's learning settings. Resetting them tells the engine computer to re-learn - aka the adaptations to the specifics of your engine. Every single engine has variances in manufacturing/parts. The ECU adapts to the differences to optimize around those differences. It can help, but inspect that boot first or you'll be adapting to a vacuum leak.
 
  • Like
Reactions: kylanjohnson

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Thanks for your replies, and @WilloCO for explaining the adaptations.

I had originally thought of the MAF but I assumed that would trigger an error code and the car would remain in limp mode until the issue was resolved. In any case I have a can of MAF cleaner and since I'll check the intake boot, I'll go ahead and clean the MAF as precaution.

During a rainy night about two months ago, I ran over a pothole in the middle of a corner at 40-50 mph and immediately both front and rear tires on my side literally blew up. That necessitated replacing all four tires - same spec, but everyone that knows my car swears (as I) that the new tires stick out just a tiny bit more than the previous threads.

While this deceleration problem has occurred in the past, I did get the ASC/ABS light issue which lights up and goes away at will, and I'm quite sure it is sensor-related, likely as a consequence of the tire blowout (which also broke both aluminum engine supports). Perhaps they are related.

@4aceman, my car is pre-facelift so it came equipped with the older ASC; I don't have any experience with DSC, but if you activate ASC, it will light up, then go away almost immediately if no longer in use. For instance, if you accelerate on asphalt but suddenly hit a patch of gravel, the tire(s) may lose and gain traction several times. ASC lights up as soon as it's activated, then switches off, flashing intermittently depending on whether you're losing or regaining traction.
 

·
Registered
Joined
·
242 Posts
Definitely scan for error codes if you can.
I had a 5 series that had the same issue that was caused by gummed up intake/exhaust position sensors. Cleaning the sensors cleared it up completely. However by the time I fixed it the catalytic converters had been damaged.
On the e46 the intake sensor can be accessed by removing the airbox (2x 10mm bolts & 5mm hex on the sensor), the exhaust sensor is more accessible (again 5mm hex)
 
1 - 9 of 9 Posts
Top