E46 Fanatics Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I am truly regretting that i ever did this E46 double din install.:banghead:
Ok First of i did the entire install myself. followed instructions very well. and everything works fine.... audio and video wise.
On the other hand now my ac is blowing but its not cold AT ALL!! and the instrument cluster wont show doors ajar or blinking signals.
-I have checked all the fuses and they are perfectly OK.
Any help would be great!!!
Because its about 100+ degrees out and the whole blinker thing is making me paranoid when I'm driving in-front of a copper.

-2000 323i is the car model
so Please HELP someone anyone:facepalm:
 

·
Registered
Joined
·
3,002 Posts
Did u plug up everything back to the a/c control unit? Also, did u wire the speed signal wire correctly and etc?
 

·
Registered
Joined
·
3,002 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
so i caved and took it to the bmw dealership they said i must have messed up the ac module somehow
urrrrrr
 

·
Registered
Joined
·
5,584 Posts
so i caved and took it to the bmw dealership they said i must have messed up the ac module somehow
urrrrrr
Cha-Ching!!!!!!
Watch them charge you $5,000 to replace every last part of the the AC system, when I'm 101% sure its just a wire you forgot to connect back up!

Man I wish I was your BMW Dealer. Them nuggas pray every day for people like you to come in with that sort of thing.

Just re-check all your wiring connections. Dude, it's normal to forget to hook something back. We are human...after all.
 
1 - 8 of 8 Posts
Top