E46 Fanatics Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I'm the old 60's/70's Muscle Car dad who has been tasked with getting my son's car running and able to sell. My son is off to college and left his mess for me to deal with!!! Here is what he has:
2004 BMW 325i E46
2.5 Litre / Automatic Trans
Oriental Blue Metallic
  • Lowered – Raceland Coilovers
  • Stage 3 Tune /
RevMatch Motorsports
  • Spectre Intake/Filter
  • Long Tube Cat-Less Headers
He always had a backyard shade tree mechanic do his exhaust mods and by the looks of things, his little brother could've done better with a soldering gun!

Onto the good part: This car ran great for months and then just last week started running really bad after about 2 miles of driving. I thought he blew a head gasket, but after checking, all 6 hold at 170-180 P.S.I. I drove it and it ran great until about 2 miles then was very sluggish (barely making it home). I did a code scan and got upstream O2 sensor 1, upstream O2 sensor 2 & all cylinders misfire.

Being that the car is lowered, I struggled to get her up in the air and found some sort of plug/sensor just hanging under the front sub-frame. Not sure if this just happened or this has always been this way since he modded the exhaust. In any case, can someone tell me what this sensor is (see pictures)? He did have aftermarket headers installed and this is near the headers.

Thanks, and please be patient with an old man!!!

Finale...My first car was a 1970 Oldsmobile 442 W-30 with a 455 Super Rocket!!!! I'm old-skool!!!
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
Days later...

Both upstream sensors are in each bank. One downstream is in bank 1. Downstream bank 2 is laying on the skid plate - That port has been welded shut. The shade-tree mechanic/shitty welder did the work stated that the car will run fine with out cats & downstream sensors since they are juts there to make sure the cats are installed. It actually ran great like this for about 4 months - All of the sudden it started running like crap and purging.

Codes are showing bad upstream bank 1 & 2.

I'm debating selling it as is and disclosing what I know...Or, risk replacing both upstreams and seeing if it runs good again and selling it as a great running car.

My mind tells me since he has this tune thing, and he loves hammering it to hear the pops & see exhaust flames (all while always using Super 93 fuel), he fouled up the sensors.

Again...Gimme an old-skool big block and I can pull horses from anywhere! This new ECU controlled crap is for teh birds!!!
 

·
Registered
Joined
·
9 Posts
Problem is we just moved into our new house 3 days ago. I have a broke down car sitting on jack-stands and look like total ******** to my neighbors! HOA does not allow this type of situation. My garage is packed with all my tools & hot rod - I am not moving my stuff outside to tear a car apart and piece sell!

There is a lot of info. on here - Thanks!
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #16 ·
We are in Bradenton. I bought two new upstream sensors, but just can't replace them with my health/disability issues. I'll sell car as-is for $2000! I just need it out of my driveway!!!
 
1 - 7 of 7 Posts
Top