E46 Fanatics Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
9,558 Posts
The locking system DOES WORK if I press the button in the centre console
So as recommended and because it looked like the Problem, I replaced the two relays in the GM5 Module. However the Problem of not being able to lock/unlock the car with the key half the time, and the Problem of the key not wanting to program to the car still persists
The first quote says the root cause is not the GM5. So, who suggested to replace the relays? It is the antenna and AMP wiring.
 

·
Registered
Joined
·
9,558 Posts
I have a sedan, if that changes anything...
That amplifier is the one that amplifies the RF signal before feeding the GM5. Look for the cable/wires that connected to that module. For the wagon the wire loom from the chassis to the trunk/boot had broken wires inside when I fixed my car with the same issue. For sedan it could be the same wire loom at the upper right rear of the trunk lid. I had to cut open the rubber to fix the broken wires.
 

·
Registered
Joined
·
9,558 Posts
I took the cover off the back, wiggled the battery and then put it back together again. Low and behold, IT WORKED! It was the battery all along. I feel so stupid right now but you cant blame me because the red LED on the key always light up when I pressed buttons so I always assumed the Key was ok.
How could the LED light turned ON when pushing the button and still the battery connection problem was the problem? Can someone explain this? I guess the remote Processor chip was in a crash mode and needed a RESET, and so by wiggling the battery that might have reset the control and it works again.
 
1 - 7 of 7 Posts
Top