BMW E46 Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #1
So I just got the P1624 SES on my 2000 e46. I know this is computer/ engine specific, so I have a 2000 328i M52tub28 engine 5 speed auto/sport :thumbdwn: I believe the date of MFG is around march of 99. I've heard it could be the thermostat with my model and year. I replaced the upper/lower coolant hoses, expansion tank, and I think the thermostat is at the bottom of the expansion tank so that was replaced as well September of 2015 . I did not replace the temp sensor on the lower hose, could that be it? Anyways just wondering if anyone has come up with this issue? Before I leave for work tomorrow I am going to check coolant level, But anything helps!
 

·
Registered
Joined
·
10,576 Posts

·
Registered
Joined
·
21 Posts
Discussion Starter #3
Ok, Thanks! Last night when I got home I cleared the code and then this morning checked coolant level, it was full. Drove to work and back about 15 minutes each way, engine heated up in normal time each way to operating temp. The light didn't come back on. Ill see if I can clean the electrical contacts on the thermostat, maybe it was just a glitch. Time will tell, Thank you for the real oem page!
 

·
Registered
Joined
·
21 Posts
Discussion Starter #4
Alright on my way to work this morning the light came back on. The engine still heated up in the regular amount of time. Does this still mean the thermostat is bad or would the problem be elsewhere in the circuit?
Thanks again.
 

·
Registered
Joined
·
21 Posts
Discussion Starter #6
Haha well it's probably the original thermostat, 188,000 miles
It's probably bad. I'll buy one from turner motersports tonight.
 

·
Registered
Joined
·
106 Posts
I just ordered the kit from ECS which includes a gallon of coolant, the t-stat, and the o-ring. All genuine BMW. I think it's like $90...
 

·
Registered
Joined
·
21 Posts
Discussion Starter #9
Shoot I wish I had known about fcpeuro, I'll buy from them next time. I bought from ecs. Thanks for the help! I'll post on here when after I replace it.
 
1 - 10 of 10 Posts
Top