BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,703 Posts
Discussion Starter #1
I recently picked up a used E46 M3 cluster on this site. It was for a 6-spd manual, and my 325ci is a manual also. I plugged it into the car and everything worked; rpm, water temp, gas, oil temp, etc. The only problem is that it has 32,000 miles on it and it says -4,900 for oil service.
Now, I have 1,300 miles on my new 325ci and it has like 13,900 left until the oil service.
I took it back out and called my dealer today hoping they would be kind enough to change the odometer and oil tracker for me. They said, this can't be done and I would have to buy a new one. I told them to shove it. I was wondering if anyone one here had some information regarding the process of re-coding the instrument cluster so I could bring it in and show them what they had to do and that it is indeed feasible.
Anyone have any info about recoding the instrument cluster, 'cause otherwise everything else works fine.


Troy J.
 

·
Registered
Joined
·
158 Posts
Your dealer is mistaken. It can be done but maybe they´re not intersted in encouraging it. I´ve seen the conversion having been done on some german boards, but I´m sorry, I can´t be more specific than that. All I know ist that the dealer basically just has to tell the cluster: "Yup youre in this car now", please reread all Information (like odo) from the ECU.

But one thing intersts me: Did the cluster really show the Oil-temp ? or was the instrument showing mpg on the Oil-temp-Instrument ? For as far as I know only the M has an oil temp sensor. So where would the cluster get the Info ?

And what about the lights in the tach ? Did they work according to plan (more and more going off when the engine warms) ?

Check this fotoseries for proof that it can be done (German unfortunately, but the pics should help)

http://www.bmw-syndikat.de/bmwsyndi...eu++mit++Facelift++Front*&Forum_Title=BMW+E46
 

·
Registered
Joined
·
158 Posts
I´m sorry, I have to correct myself.
I checked out some threads in German forums, and it seems that you can only use a brand new cluster. They can be coded to fit the car only once. With a used unit there´s trouble.
 

·
Registered
Joined
·
1,968 Posts
Tierfreund said:
I´m sorry, I have to correct myself.
I checked out some threads in German forums, and it seems that you can only use a brand new cluster. They can be coded to fit the car only once. With a used unit there´s trouble.
This makes a lot of sense... people could swap clusters at time of trade in/sales for one with less miles otherwise. :hmm:
 

·
Registered
Joined
·
1,703 Posts
Discussion Starter #5
The oil temp did indeed work. I have a 5-spd manual and that one was from a m3 manual. It gradually raised up while the engine was warming. The re-line thingy's didn't work. This just went to a defualt red-LED starting at 7500. The tach did work immediately, ending at 6500. I guess I will just buy a new m3 cluster from crevier and have my dealer program that.



Troy J.
 
1 - 5 of 5 Posts
Top