E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello Peoples,

I have an e46 m3 SMG with 55k on it.

I recently noticed something strange going on with the shifts, especially with the sport mode on and any of the S1-6 settings.

Where issue arises: Under full throttle from 2nd shifting into 3rd or 3rd into 4th,...etc. (Main factor is full throttle)

I noticed that it was not grabbing the gear quickly and It felt like the car was slightly sluggish in engaging the gear. The numbers blink properly and I do not have any Modifications. I tried all settings s1-6, sport mode on/off, still with the same results.

At redline, it is SUPER Harsh, which i assumed to be normal of course, but under full throttle between 3000rpm to 7000rpm, it is extremely sluggish.

I thought clutch? I tried all gears cruising at 40mph and there is no slipping. I did the SMG factory reset (paddles), still very sluggish gear change.

I once had upgraded the intake to the K&N full intake and it set off the check engine light. Replaced the K&N intake with OEM and took it to the dealer. Dealer said the MAF sensor is bad. I never replaced it. When i got the car back, the check engine light went off and never came back on.

Could the bad MAF sensor cause the sluggish gear change?

To be honest, its even sluggish when down shifting as well.

Needs some help please!!!
 

·
Registered
Joined
·
1,263 Posts
hm.. sluggish downshifting as well? Never heard of that scenario before.

Does it feel like the clutch is slipping? (Maybe premature wear) but you only have 55k with SMG, so that's unlikely at this stage.

Check m3f.net, those boys should help you out. I always tell people for problems, just go straight there.
 

·
Registered
Joined
·
54 Posts
I would replace the $15 salmon relay first if you haven't already. Start with the easiest and cheapest solution first.

Sent from my XT720 using Bimmer App
 

·
Registered
Joined
·
106 Posts
02 SMG m3 here: I have had this identical problem for over a year now! Good luck on figuring it out. I even took my m3 to the bmw dealership an had them drop the transmission and check/inspect everything , they said that they found nothing wrong with my car or transmission all while charging me $800 bucks.

If you by chance figure out your issue please PM. with what you find! Goodluck

PS> I upgraded my clutch thinking it might be the issue NOPE didnt change a damn thing.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
In addition, I have never had the SMG light come on and I baby the hell out my car and its engine. No leaks as well. Im pretty sure its not clutch as well because the car still pulls pretty hard once the gear engages. I find it weird why its not sluggish at redline or prehaps i am not feeling it.

Im still going to take it to the dealer to see what they say. I have a feeling its going to be the MAF, which they said would cost $900 for some odd reason.
 

·
Registered
Joined
·
318 Posts
Not the clutch. Before you do anything replace the salmon relay. Next it's worthwhile getting both the clutch 'bite point' and the SMG calibration done. Don't just get the clutch done, do both. If the SMG calibration fails (it'll probably say 'replace gearbox'!) then almost guaranteed you've got one or more broken indent springs. Replace them all, get the SMG calibration done again and you should be sweet. If none of the above then the next likely culprit would be the GPT- Gear Position Transducer (Sensor), which is what the SMG calibration is actually calibrating.

Good luck. Report back.

Cheers
JM
 

·
Registered
Joined
·
1,987 Posts
In addition, I have never had the SMG light come on and I baby the hell out my car and its engine. No leaks as well. Im pretty sure its not clutch as well because the car still pulls pretty hard once the gear engages. I find it weird why its not sluggish at redline or prehaps i am not feeling it.

Im still going to take it to the dealer to see what they say. I have a feeling its going to be the MAF, which they said would cost $900 for some odd reason.

If you think its the MAF, DIY it and get some electronics cleaner spray to clean it. Cheap fix for that. Next option would be to have an indy check it out....I wouldn't pay dealersh, er, I mean stealership prices
 
1 - 10 of 10 Posts
Top