BMW E46 Fanatics Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1 (Edited)
Issues with Sirius tuner on 2004 323ci

--------------------------------------------------------------------------------

I just purchased a 2004 323ci convertible. I had a Sirius tuner (65120398140) installed in the trunk. My business cd head unit does not recognize the tuner. When the mode button is pressed it switches from FM to CD and there isn any "sat" option. I called Sirius and was told that the tuner wasn't active and they sent a signal several times and I didn't have any luck. I also disconnected and reconnected the battery and didn't have any luck

My question: Does it sound like the tuner has to be "flashed" or programmed by the dealership? I also realize that the tuner may not be functioning properly.

Has anyone had to have their Sirius tuner flashed? Before is was flashed, was the tuner not being recognized by the car? In hindsight, I should have just paid the dealership to install the whole thing and saved myself quite a bit of aggravation. I would appreciate any feedback. Thank you.

Aidan
 

·
Premium Member
Joined
·
28,970 Posts
Search around here and on other forums for more info on the module part number. It has nothing to do with whether or not the receiver has been activated by Sirius, you should be able to communicate with the receiver module either way.

There are 2 receivers, one for NAV equipped cars and one without NAV.

My 2006 E46 330cic has module part number 84110141981. I cannot recall the NAV bases module number, I would have to dig it out.

I am not sure where you receiver your module/part number, it appears a bit unusual??
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3 (Edited)
It is has been so difficult trying to get this done. DO you think that after having it flashed that my car would recognize it?

IS it that this tuner is for cars with nav and my car does not have nav?
 

·
Premium Member
Joined
·
28,970 Posts
Search around a bit more, I cannot confirm for sure.

You apparently have a new version receiver, however, it is unclear if the newer versions still had NAV & non NAV models??

See this link for some ideas, but you will need to search around a bit more.

http://www.bimmerfest.com/forums/showthread.php?t=611008

Did your car have a rear trunk CD player?

Mind did not, but I also have an E39 M5 with NAV and 6 CD player in the trunk that I added Sirius to and there is a wiring harness that connects the CD player through Sirius receiver.

You also need to be a bit careful as there are some variations in the actual radio module that may impact the ability to recognize the receiver as well? I know that a different radio receiver model is required to have an Aux input on some models as well.

There is not a lot of info available as not many people have performed retrofits and the dealers are usually not much help.
 

·
Registered
Joined
·
187 Posts
I had the same issue when I was installing my blitz safe xm. I don't recall how to do it, but make sure you have the region set to US. I think the default to ECE, which will not allow Sirius.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
Do you remember how you figured it out? I am not sure whether to try to have it flashed or buy a different tuner. You are saying that the business cd needs to be set to "US"?
 

·
Registered
Joined
·
1,458 Posts
Even unactivated, the head unit should recognize the tuner. Mine would say "call sirius" or something like that prior to activation.
 

·
Registered
Joined
·
1,458 Posts
Looks like you have a compatible part number, according to delmarco's thread that I used for my own install. The install on this is literally unplug cd changer, plug in sirius. You have a dead receiver perhaps? Your head unit has the Mode button I assume, being that it's an 04 it should, but dont make any assumptions, id pull it and check the date stamp on the bottom.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
THanks for your help guys. I ordered a new receiver and I should receive it during the next couple of days. I think that it had to be a bad receiver. THe antenna and wiring was fine.
 
1 - 10 of 10 Posts
Top