E46 Fanatics Forum banner
1 - 18 of 18 Posts

·
Registered
2016 340i xD 6-spd
Joined
·
26,645 Posts
Either read a lot more threads...maybe think 02 emulators among other things...or return it to the way the car came from the factory--I know it won't act up then!

Acts like it's 'loading up'? Maybe you can explain that for the guys here that might actually be able to help. You might also want to report if you have a cel or any codes.
 

·
Registered
2016 340i xD 6-spd
Joined
·
26,645 Posts
The intake manifold was cracked? You replaced it? Or your exhaust mani was cracked and that's why you replaced it?

I can't imagine how either could be cracked but I guess someone took a hammer to one or the other.

This is your wife's car you were trying to get some more hps out of?

cel is 'check engine light'

Maybe you should also say what brand of AM headers you got and from where. They're not all created equal.
 

·
Registered
2016 340i xD 6-spd
Joined
·
26,645 Posts
I asked about intake because you said you were sucking air.

Maybe on exhaust side, a crack might still suck in air and cause a lean code, but that's beyond me. GL!
 

·
:D
Joined
·
7,274 Posts
I'm pretty sure you either need an 02 sim to make your car think you have 02 sensors or you need a euro tune done.
What exactly did you do with you sensors?
 

·
:D
Joined
·
7,274 Posts
i put them back into this great ebay set of headers after i had to change a few things with them,and i didnt mark them i just laided them out by the sides they came off of
Ok yeah. Your 02 sensors aren't happy because you no longer have cats to clean the fumes.
If I'm thinking correctly you should have a code that says youre running rich. But either way you will have a cel without cats.

Try unplugging your battery for an hour or so and see if that helps.
 

·
:D
Joined
·
7,274 Posts
You either need to get an o2 sim or a tune. Both will cost money.
And both should also let you pass emissions but I'm not 100% sure about that.
Hopefully you don't have emissions there.
 

·
:D
Joined
·
7,274 Posts
you get a tune that eliminates the light. I'm surprised someone in California got rid of their cats
You're in California!? Dude. Why did you do that? How the hell do you plan to pass emissions
 

·
Registered
2016 340i xD 6-spd
Joined
·
26,645 Posts
smh

OP, be careful. You replaced a major part of your engine without knowing lots of stuff you should have. You might work through this issue with headers install, but in the future with other engine work, spend more time studying. I used to say a while back that you should read/watch diys until you're nauseous or convulsing. The more complicated something is, the sicker you need to be if you're doing it just from reading/watching it done and not having actually seen it live or having done it yourself many times. There are always little things that are easy to miss...and missing that little can be missing the mark a lot in some cases.

Did you try disconnecting the maf to see if things smooth out?

I don't think you're really running lean but the car is probably thinking you are and probably using lots of extra fuel to compensate.

BTW, I'm guessing at all this if you didn't get that sense already! I'm not a mechanic and am religiously stock. Even have a bmw shrine and all!
 

·
Banned
Joined
·
2,014 Posts
it doesn't hurt to double check your 02 sensors and make sure they are installed in the correct banks. I hope this helps. good luck
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top