BMW E46 Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
279 Posts
Discussion Starter #1
Hi All -

New owner of a CPO 2003 325i w/ 14k miles on it, step transmission. I love it, but:

Driving home today and noticed two issues I don't undertand:

1) headed uphill in 4th at approx 2500 rpms, applying throttle resulted in surging, like the car was trying to accelerate but having fuel cut. It accelerated through the surge and by 3000 rpm all was fine. Not violent by any means, but strange sensation.

2) Late in the drive I was coasting downhill and the Service Engine Soon light came on. Got home, shut off car, turned key to position 1 and both SES light and EML light came on. Started car, both stayed lit then EML light turned off after ~5 seconds.

Car *seems* to run fine, but I'm taking it in tomorrow (after two days of ownership). Am a little freaked about maybe having bought someone's problem car.

Anyone ever hear about this stuff? Gas cap is indeed on tight, by the way. What could this likely be?

Thank you,
Matt
 

·
Registered
Joined
·
279 Posts
Discussion Starter #2
Bump.

C'mon friends - my preliminary research (on boards like these) points to:

1) software problem
2) defective throttle body
3) O2 sensor
4) cam position sensor

At this point I'm ruling out the gas cap as I haven't put gas in the car yet and it's tight. Also, on 2003 325 models there is a separate "gas cap loose" dummy light next to the "Service Engine Soon" light.

Drove in to work today - car seems to work fine. Service at BMW Mountain View hasn't yet returned my call.

Other ideas? Please? I really like having ideas and demonstrating that I've researched problems before talking with them so I don't get the runaround, non-answers, non-solutions or a blase attitude from service people. You gotta engage them.
 

·
Registered
Joined
·
279 Posts
Discussion Starter #3
Okay

Further research points to DME software upgrade, although most people have had it done for stalling and really rough idle (I have neither of those symptoms).

S/W upgrade is also what the dealer service agent says needs to be done for both the SES/EML lights and the surging I'm getting with light thottle while climbing.

Sounds like the cheapest fix. I'll be sure to get the codes that popped and report tomorrow when I get the car back.

Thanks for the fountain of knowledge, guys.

Matt
 

·
Registered
Joined
·
279 Posts
Discussion Starter #4
DME flash/upgrade program cured both lights and surging.

There were pre-cat bank and post-cat bank O2 codes as well as a misfire code.
 
1 - 4 of 4 Posts
Top