BMW E46 Fanatics Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2001 BMW Z3M Roadster that I've been chasing this 'rattle' noise to no avail. I thought the noise was related to the fan clutch which I just replaced this past weekend, but that didn't do it. It only occurs at idle and disappears when the engine is revved up a bit. There's no loss of power, rough idle, or CEL associated with it at all.

Just a bit of background, I purchased the car about a year ago from the original owner with just over 98k miles and the car currently has just under 100k miles. Since taking ownership, I've had all of the fluids changed, spark plugs / coils, valve adjustment / gaskets, power steering pump replaced, and fan clutch.

My only other thoughts are it could be related to the Vanos or the idler pulley / tensioner (both of which haven't been touched by the original owner) or I simply have something wobbling around in the engine bay that I can't see. I haven't been able to find a video of an S54 making a similar noise, but below is a video of my car running. I was really hoping to take the car on a road trip this weekend, but now I'm not so sure...

https://www.youtube.com/watch?v=8ZfqTsVZV1g
 

·
Registered
Joined
·
5 Posts
Discussion Starter #2
Here's another video of revving the motor up a bit. As mentioned, the noise goes away when the engine is revved. It also sounds like it might be coming from the air plenum or the fuel rail. Not sure if it could possibly be a bad injector?

https://youtu.be/becVStrdB0Q
 

·
Registered
Joined
·
1 Posts
Did you ever figure this out or replace anything? I know it's kind of hard to hear in the video, but this is the EXACT same noise my engine is making at idle and it also disappears after idle as well.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Did you ever figure this out or replace anything? I know it's kind of hard to hear in the video, but this is the EXACT same noise my engine is making at idle and it also disappears after idle as well.
So I didn't end up replacing anything but actually was forced to daily the car for a couple months and the noise simply went away. Not sure if it could have been related to not driving the car enough (I was only driving it a couple days a month) but the noise is completely gone. I will likely address the Vanos in the spring for piece of mind, but I don't think the noise was related.
 
1 - 5 of 5 Posts
Top