E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 10 of 10 Posts

·
Registered
Joined
·
169 Posts
Discussion Starter · #1 ·
I have an 03 M3 and today I drove to the tire shop and everything was fine. When I started my car to go home it had a rough idle and very low power. My car sounded like a WRX STI. Check engine light came on and these are the codes I got. Any help would be greatly appreciated. Thanks.

P1344
P1348
P1349
P0316
P1346
P1347
P1341
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #3 ·
FYI. Codes are for cylinder 234 misfire and fuel cut off. Multiple cylinder misfire. Misfire below 1000 rpm.

Also if anyone has a good website to buy quality BMW replacement parts at a reasonable price. Thanks.
 

·
Registered
Joined
·
3,837 Posts
Start by changing your fuel filter. It is obvious that you have had a fuel problem. Could be water in fuel or something else. Ask me how I know. Hopefully it's not the injectors.
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #6 ·
Thanks. U said to ask how u know this. My guess is it happened to u first.

I spoke to my father who is a certified mechanic and he also said it could be bad gas. He told me to put two bottles of octane boost in the fuel and some mystery oil in the engine and fuel tank. I will try this an let u guys know how it works out.
 

·
Registered
Joined
·
3,837 Posts
Yes, right after I filled my wife's e34 touring last week, the idle was all over the place and low on power. Then it died. I waited 5-10 minutes, started it up, and barely made it home. Next morning I siphoned 4 gallons of gas out, put some dry gas and drove straight to my mechanic. Sure enough the fuel filter was clogged due to bad and watery fuel.

Yours might be clogging up for some time. My suggestion is don't drive it before you have the fuel filter changed or you'll risk damage to the fuel pump, and it will cost you $$$. Another car was at my mechanics shop for the exact same reason, but the owner kept driving it to the point that it'll cost her close to a grand to fix it.

I talked to the gas station, they were aware of the problem, and they paid for my repair. I have since filled up once (after burning all the bad fuel in the tank) with Shell 93 and it now runs like a champ. Won't be trusting anywhere else with my gas from now on.
 

·
Registered
Joined
·
169 Posts
Discussion Starter · #8 ·
Problem was not the fuel. It was a bad coil. That coil caused cyl. 4 to misfire consistently with the other cylinders misfiring sporadically. I did a full tune up and the car is running better than ever.
 

·
Registered
Joined
·
16 Posts
i just started having the same problem this morning. i have an 05 m3. sounds like a wrx, rough idle, service engine light is on and barely no power. it moves, it just take longer to get there.
 
1 - 10 of 10 Posts
Top