BMW E46 Fanatics Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter #1
What's up guys I have a 2003 330i i recently bought a engine because the one I had was blown so when I bought the engine it was from a manual 330i and my car has a automatic smg transmission now do I have to reprogram the engine to the transmission because I have a problem with the throddle response and no acceleration I know its not the throddle body because my old one worked great so any clue will help at this point car has been down for a year and its driving me nuts
 

·
Registered
Joined
·
8,567 Posts
What's up guys I have a 2003 330i i recently bought a engine because the one I had was blown so when I bought the engine it was from a manual 330i and my car has a automatic smg transmission now do I have to reprogram the engine to the transmission because I have a problem with the throddle response and no acceleration I know its not the throddle body because my old one worked great so any clue will help at this point car has been down for a year and its driving me nuts
Maybe you have to clear adaptations with inpa?
 

·
Registered
Joined
·
112 Posts
If you use the same DME that was in the car originally, there should be no need to reprogram the DME. The engine from a MT is the same hardware as used with the SMG trans. There must be something else wrong. Did you scan for fault codes in the engine and trans controllers?
 

·
Registered
Joined
·
10,605 Posts
The engine and the EGS (tranny computer) have to communicate. If the DME (engine computer) isn't aware that the EGS exists the 2 computers won't communicate. I'm betting the 2 computers have to be "introduced."
 

·
/// Limitless
Joined
·
3,505 Posts
The coding for the automatic lives in the cluster and the light control module so the DME, whether it came from the new engine or not should not make a difference. If you're using the new DME you will have to clear all adaptations and align the DME with the EWS module.

Terraphantm suggested that all that is necessary is to clear all adaptations, however when I did my tranny swap that didn't seem to stop my DME from scanning the bus looking for the non-existent EGS controller so I fully reprogrammed the DME, which stopped the scanning and then aligned the DME with the EWS module.

So if clearing adaptations doesn't seem to work then reprogram the DME and align with EWS.

I did all that with SSS Progman and DIS.
 

·
Registered
Joined
·
112 Posts
The only difference is that the "new" engine came from a MT car. Therefore nothing else would be different, or need recoding of the original existing DME, EGS or cluster. Those control modules won't see anything different since the two engines are identical. The problems described by the OP, must be caused by some other malfunction/s.
 

·
Registered
Joined
·
54 Posts
Discussion Starter #7
The shop told me that the car is not responding ima get more info today they said it might be a wireing issue I don't see how cause all I did was change the engine lol
 
1 - 7 of 7 Posts
Top