BMW E46 Fanatics Forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey all, long time lurker, first time poster.

For the past 8 months or so, I've been having the weirdest electrical system issues. Symptoms included my brake lights staying on constantly, the horn not working, the steering wheel controls not working, and causing the stereo to turn off when the vanity mirror light came on. Also, the radio would get unbearably staticky, especially when the rear defroster was on, and the tail light indicator would come on randomly. Most of these issues would come and go randomly, and I couldn't do much to change how or when they appeared. For a few months, I was able to fix the issue by opening the vanity mirror and jiggling the wires connected to the ignition switch, but that stopped working after a while.

Eventually, I was able to narrow the problem down to either a K-Bus issue, or an ignition switch issue. The K-Bus issue seemed more likely, so a spent a couple of hours upside down in my passenger seat pulling various connections off of it in an attempt to isolate the issue, following this guide. That didn't get me anywhere, however. I then bought a used ignition switch and installed it following this guide.

As you already noticed, replacing the ignition switch solved the issue! :woot: Now I can use cruise control and honk at people who are trying to hit me! Anyway, I figure this might help someone track down the cause of their crazy electrical problems._a_
 
1 - 1 of 1 Posts
Top