BMW E46 Fanatics Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
My 2001 5spd 100,800mile 330cic e46 seems to be having this very random problem with stalling. As of 2011 it has happened to me twice already. The car will be driving fine and then all of a sudden it will lose 90% of it's power. Then as I stop (for fear of damaging the car) it will just die. I will try to restart and it will start to die and the car will rev itself a bit to try and prevent a stall. but then it does stall. After letting the car sit for an hour it will start up fine and I can drive home with no issues, any earlier and it just dies. the only things that I can put together are that it was 80degrees F (or above) outside both times, and i had been driving for more then 15 min before it started to happen. also the temp guage stays at normal operating temp.
I have looked almost two weeks for a solution but can't seem to find any posts similar to my issue.

I have also done a smoke test to check for intake leaks and when I read the computer it said I was only getting a misfires in bank.
My only guess is an overheated fuel pump or a bad cat on bank 1.

Very recently i have replaced:
Fuel Filter
spark plugs
o2 sensor
maf

It is really starting to worry me because right now the weather is cold but as we get closer to summer the problem will definatly occur more often
 

·
Registered
Joined
·
26,311 Posts
If you search 'idle surging' you'll see a lot of the stalling there too.

I'm not sure your smoking from the outside would tell you if you have a broken intake boot (lower one in all liklihood)...if that's the kind of smoking you did.

That it happens when the car is warmed up makes me think the boot more. When rubber is warmed up, will become more pliable and a crack, under throttle, will open up wider.

While there, do all the cleaning and replacing of stuff that you can...disa, icv, tb.

That's just my random guess, but I had stalling and now I don't. Just saying what I said worked for my stall, but I also had a surging idle. YMMV
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
I did the smoke test found nothing and the intake boot I already checked in hopes of a cheap fix.

Sent from my SAMSUNG-SGH-I897 using Bimmer App
 
1 - 3 of 3 Posts
Top