BMW E46 Fanatics Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
636 Posts
Discussion Starter #1
the windshield fluid just leaked out like a hose and i found out that this part was disconnected....what is this?!





any clue what or how to solve this??
thanks in advance friends!
 

·
Registered
Joined
·
57 Posts
it looks like you need a new windshield washer fluid reservoir (very easy only one 10mm bolt)
however, if you ran over a speed bump at any kind of destructive speed, the washer reservoir should be the least of your concerns.
 

·
Registered
Joined
·
636 Posts
Discussion Starter #5
it was actually more like a pot hole...speed bump was kinda a over kill...lol
 

·
Registered
Joined
·
5,881 Posts
Looks like it should just plug right into your pump's fluid output, which is right there in the picture.
 

·
Registered
Joined
·
141 Posts
It's for your headlight washers. It's the hose that connects to the washer pump. Hook it back up, refill washer tank and you're good to go.
 

·
Registered
Joined
·
70 Posts
I'm kind of in the same situation, when I had my car really low I scrapped the chasis on a speed bump then the next day I was out of fluid. I filled it up a couple time since then but leaks out within a day or two. Going to be looking into it tomorrow, not really wanting to buy a new tank...I heard they were expensive.


Sent from my SPH-D700 using Bimmer
 

·
Registered
Joined
·
636 Posts
Discussion Starter #10
I tried to reconnect it but the plastic snapped off... It won't reconnect..
 
1 - 11 of 11 Posts
Top