E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of September's Ride of the Month Challenge!
1 - 7 of 7 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 · (Edited)
Okey, so I got this problem. I was traveling home, and everything seemed normal. After 30min of driving, the engine started to "lag". But this was only uphill, or when I tried to accelerate.:ben:
When I stop and put the clutch in, it runs normal! everything seems normal, even when I rev the engine.
So, I tried to continue my way back home, but as soon as I hit the throttle a little bit, it started to "lag" again. :tsk:
I did try to push it a little, and then the "CEL" started to blink. I let off the throttle, and the lamp stopped blinking and went dark. I drove home and parked the car.
Today, I started the car again, and went down to the gas station. I bought "condensation remover" and filled the tank fully up. This did not change a thing, it still lags when I accelerate or driveing uphill.
Once again, I did try to push it, and gave full throttle. Now the "CEL" started to blink again but now it stays on.:thumbdwn:

Anyone got any idea, what it might be?:eeps:

(This is an 316i 2004 if it helps).:p
Thank you for help.:clap:
 

·
Registered
Joined
·
11 Posts
if the CEL is on > that means the vehicle is "throwing a code">> the DME sensors have detected a fault >> get a OBD-II reader - plug it into the OBD-II port and read the codes... >> they will be the source of your problem >> or at least part of th eproblem
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
if the CEL is on > that means the vehicle is "throwing a code">> the DME sensors have detected a fault >> get a OBD-II reader - plug it into the OBD-II port and read the codes... >> they will be the source of your problem >> or at least part of th eproblem
Yeah, that was what I figured out too, so the car is delivered to a workshop to read the codes.

Do you know if a obd2 reader from ebay works fine? And what about the types with bluetooth?

Like this:
http://m.ebay.com/itm/252420291696?_trkparms=pageci:6f6a8b2e-ab77-11e6-8c33-74dbd1806d56%7Cparentrq:69d061ac1580a605b6204460fff7cc51%7Ciid:5&_mwBanner=1
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #7 · (Edited)
Got this codes:

2E95
2A69
2E26
29CC
29CF

Now I have changed coil nr 3 but still the same!
I took the coil from another car that is 100% same (but the coil did look a bit different)

Any ideas?
 
1 - 7 of 7 Posts
Top