E46 Fanatics Forum banner
41 - 43 of 43 Posts

·
Registered
Joined
·
2 Posts
Hello.
I have a 2002 330CI convertible. M54 engine series. Manual.
This car does not have a cable for the throttle. Drive by wire.
Symptoms:
Start car, no SEL lights or diagnostics.
With car in neutral or in gear, clutch pressed or not, I can rev the engine, good response. idle is also good.
The moment I press the brake pedal, the accelerator no longer revs the engine.

Short background. Car ran well before this. I replaced the air filter. Changed the oil. I did disconnect the MAF while replacing the air filter. But was very sure to reconnect it. However I did not disconnect the battery.
When this happened the first time I did get the DSC light to come on. Was backing up on a slight incline.
To make this go away I restart the car, the gas pedal revs the engine well.
the moment I hit the brake pedal it disable the gas pedal.
I need some help. Thank You Lucas330CI

Also wanted to add that once the brake pedal is pressed the engines stays in perfect idle. around 750 rpm ( approx)
I have tried disconnected the battery for several minutes and reconnected.
 

·
Registered
Joined
·
1 Posts
There are many instances where you can press the brakes and accelerator at the same time especially if you have a manual transmission car. Rev-matching and heel and toe techniques can be fun and very useful for smoother/quicker shifts.

OP: I can't think of why this issue would occur,but here is a link I found describing something similar, and it turns out that case was due to the owner forgetting to plug in the MAF sensor. I'm curious to see why this happened so keep us posted when you find the solution. No throttle when brake pedal is pressed. [Archive] - BMW E46 330 ZHP For Sale Forum | 330i/Ci BMW ZHP Performance Package
I was having the same issue after changing the alternator and forgot to plug in the MAF on the intake tube 👍 problem solved thanks
 
41 - 43 of 43 Posts
Top