E46 Fanatics Forum banner

Power Steering behaving weirdly after engine swap

1020 Views 10 Replies 4 Participants Last post by  Cvariable
Hi again!
After swapping an M54 into my N42 2003 Touring with a blown engine, i've just managed to get it driving for the first time.
At first, the power steering worked, but after ~5 minutes it suddenly seemed like it was completely gone. After shutting the car down and starting it again a little later it seemed like there was a little bit of assistance, but not as much as there was at the start.
However, the reservoir is completely full and there doesn't seem to be any leaks. When turning, i do notice the engine idle dropping slightly as if the pump was working. The power steering cooler is slightly warm. The fluid is purple-pink as it should be, since i put in like 1 liter.
All over this forum, i read that the pumps go bad a lot. However, i would be very surprised at the timing of that - just after the swap?
During the install and the first start, i had fluid in the reservoir, but after first starting it that fluid did not get sucked in by the pump. Only after pushing to reach full lock a few times, all the fluid was suddenly sucked out of the reservoir, and after i had refilled it the power steering seemed to work fine. That might however mean that the pump ran without oil for a few minutes.
What could be a reason for the pump going bad? Is it possible that the steering rack collected too much moisture while unconnected, or that the pumps from different engines have different pressure levels? the steering rack connectors seemed to go in no problem. Is it possible i connected the power steering system the wrong way? It wouldn't have worked then, right?
Do you think the pump is bad? Could there be another issue like too much moisture or air in the system? I'd be thankful for any help here, as i didn't encounter anyone else having this issue right after a swap.
See less See more
1 - 2 of 11 Posts
How old are the lines? They might be collapsing, restricting the flow.
I've done some more testing today and found that even with the engine warm, revving over 1500 brings the assist back full-force. Under 1000 i have nothing, I've thus ordered a new pump and will post an update once it's fitted.
Since all the hoses have been working before the install, i don't think they're the issue, but it's definetly something to keep in mind. thanks for the help :)
If it were me I'd do the pump and the hoses at the same time and be done with it.
1 - 2 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.