BMW E46 Fanatics Forum banner

1 - 20 of 27 Posts

·
Registered
Joined
·
712 Posts
Discussion Starter #1
I just experience the stalling problem some people with the ZHP pkg experienced a few days ago.

Basically, I came back from a fairly long drive(~100miles each way). When I was coming to a stop at a light, downtown, I disengaged the clutch, and the RPM dropped, while the car was still rolling to the stop light, the engine stalled. I didn't even notice until I tried to gas up and noticed that the car wasn't moving.

Anyhow, for the rest of the evening, even after a couple of restarts, the engine idle would be very rough. It'd drop below 500RPM, then all the sudden kick up to like 1.2k-1.5k rpm. I was VERY nervous all night.

All this was while I had about 1/4 tank of gas left. I gassed up later that night, and went home. The problem was gone the next day.

So I took it to my dealer, told them of the problem. Of course they couldn't reproduce it, but they raised my idling RPM in the DME to like 800 or so. Is this a acceptable fix? Will it cause issues on long idles, IE bad traffic jams etc?

TIA
 

·
'a certain moderator'
Joined
·
38,195 Posts
same thing happened to my car. they replaced the Idle Control Valve, and re-downloaded the latest version of the DMS software.
 

·
Registered
Joined
·
185 Posts
Have the same problem... Went to the dealer and they identified it as bad software. They reloaded it and guess what: It stalled on me again about a week ago. Software is not a fix. I hope bmw figures it out soon...
 

·
Registered
Joined
·
304 Posts
There's an update out at your dealer for it. They did mine when I was in there for a flat tire.
 

·
Registered
Joined
·
712 Posts
Discussion Starter #5
RebelYell said:
There's an update out at your dealer for it. They did mine when I was in there for a flat tire.
Do u know what the update is? IE number?

Cuz my dealer said that they looked it up, but there's been no bulletin regarding the issue.
 

·
Registered
Joined
·
304 Posts
otacon said:


Do u know what the update is? IE number?

Cuz my dealer said that they looked it up, but there's been no bulletin regarding the issue.
No clue. Its a cold start issue which is starting to crop up now that the weather is changing. He was just like, "we're gonan go ahead and do this update for you since its here." All I said was thanks. :dunno:

Sorry I can't be of more help.
 

·
Registered
Joined
·
712 Posts
Discussion Starter #7
RebelYell said:


No clue. Its a cold start issue which is starting to crop up now that the weather is changing. He was just like, "we're gonan go ahead and do this update for you since its here." All I said was thanks. :dunno:

Sorry I can't be of more help.
I think u may be refering to the lighting. There was a recall that they reprogramed while I was there, it has to do with starting the car in the cold, something with lights not turning on.

But I'll call tomorrow and make sure. Thanx.
 

·
Banned
Joined
·
4,174 Posts
Does your car's RPM jump around when you first start your car up in the morning? Mines does and i'm not sure if that will lead to stalling later on.
 

·
like ma bell, i got the...
Joined
·
1,233 Posts
my ZHP is constantly idling rough ... it probably dips to like 400-500 RPM's 2-3 times a day. When it does the entire car shakes and the engine revs back up above 1k and steadies itself. this has been happening since the early fall when it wasn't cold at all. mine has never stalled though. knock on wood!
 

·
Banned
Joined
·
4,174 Posts
I have never had mines dip past 500 rpms yet. I think that all the zhp's has some kind of software problem. I hope when i bring my car in, they won't say that it is normal for the rpms to jump everywere.
 

·
.--. . -. .. ...
Joined
·
5,540 Posts
TeKNiC330 said:
Does your car's RPM jump around when you first start your car up in the morning? Mines does and i'm not sure if that will lead to stalling later on.
No ZHP here, but mine does the SAME thing. You start it up, and it idles normal for around 1 second or so. Then it drops and kicks back up, but then mine stalls, unless I give it a little gas.

When its kicking back up, the car shakes a little and it doesnt sound good either.

Is this just a manual thing or do those w/ step have this too?
 

·
Banned
Joined
·
4,174 Posts
cowmoo32 said:


No ZHP here, but mine does the SAME thing. You start it up, and it idles normal for around 1 second or so. Then it drops and kicks back up, but then mine stalls, unless I give it a little gas.

When its kicking back up, the car shakes a little and it doesnt sound good either.
Time for a visit to the BMW dealer for us then. :thumbup:
 

·
Registered
Joined
·
104 Posts
Same problem, but when they attempted to upload the new software my ECM went bad. Car wouldn't even run after that and is down for the count until Tuesday.

:(
 

·
Registered
Joined
·
712 Posts
Discussion Starter #14
It looks like that the '03 ZHP and '04+ are all usinng a varient of the same engine software. They need better QA.

But mine never did idle rough, I mean, the neelde seems to stay pretty stable, just the car isn't as smooth as my 330xi ('02). I mean, when idling, in the Xi, I can't feel the engine at all, but the ZHP u can feel the vibrations.

Mine never exhibited any issues until that day. I'm wondering if the weather has something to do with it. I mean, the day before, the temp dropped to about 30-32F, but then went up to like 78F or so. I had about a quarter tank, so I'm wondering if there's condensation build up and water go into the engine. The problem went away after I filled up the tank. I'm trying to keep the tank as full as I can. The local Exxon has specials every Tue + Thurs so maybe that'll help.
 

·
Registered
Joined
·
304 Posts
otacon said:


I think u may be refering to the lighting. There was a recall that they reprogramed while I was there, it has to do with starting the car in the cold, something with lights not turning on.

But I'll call tomorrow and make sure. Thanx.

No definently had to do with stalling.
 

·
ProjectTechnik
Joined
·
798 Posts
Mine idles rough as well, every once in a while, it will drop 500 rpm and then go back up, but the car feels like it will stall. When I took it to the dealership, they said they could not find anything. So how would you say to them that the Idle thing needs to be fixed!?
 

·
Registered
Joined
·
304 Posts
I just want to clarify my earlier post. My service rep specifically mentioned it had to do with idle and cold starts. i don't know what the bulletin was called or anything but he took care fo it for me but then again I had not had any problems. BUT this is Texas after all, it just this weekend got cold.
 

·
Registered
Joined
·
712 Posts
Discussion Starter #18
RebelYell said:
I just want to clarify my earlier post. My service rep specifically mentioned it had to do with idle and cold starts. i don't know what the bulletin was called or anything but he took care fo it for me but then again I had not had any problems. BUT this is Texas after all, it just this weekend got cold.
Do u still have the service order? The recall should be listed.

Thanx.
 
1 - 20 of 27 Posts
Top