BMW E46 Fanatics Forum banner

1 - 20 of 49 Posts

·
Sofa-king-what
Joined
·
1,928 Posts
Discussion Starter #1

·
Sofa-king-what
Joined
·
1,928 Posts
Discussion Starter #4
No ideas, but maybe this E46 PDC retrofit guide can help?
https://bmw.etk.club/eba_docs/552en.pdf
Hi Bali, thanks for answering
the sys was already on the car, i changed the bumper (to an Mtech) as i've been rear ended in april, and the accident damaged 2 sensors and part of the wiring.
i've changed the sensors first but there was a problem to the outer right wiring, made a false contact for the live wire and sometimes this caused the malfunction of the sys with the 5 sec error beep (mostly on wet weather)
fixed that i couldn't hear anything except that weird sound of the 2nd video (but only via inpa test)
all 4 sensors are working 100%

what makes me :hmm: are the 1080 error of SSS and the PDC STATUS
take a look to what happens when i switch to R: REVERSE GEAR via pin 12 and then via BUS2

i've already followed the guide, but instead of DIS i've used SSS as my DIS is v57 that has no coding functions.

probably updating the sw of PDC module (that is a V.1 from '99) would reset the whole sys, but honestlyi dunno where to start from...
 

·
Sofa-king-what
Joined
·
1,928 Posts
Discussion Starter #7
yesterday I (finally) found enough time to take a deep look to this problem.
and by using different SW i discovered that:

[PROGMAN]
Pdc stills not listed into Progman available ECUs: if i try to retrofit that, i still have the above mentioned error (CoApi 1080, which stills unknown to me), if i just try to recode it, it obviously give the an other CoApi error (related to missing VO)
[INPA]
PDC is fully recognized, all sensor are showing correct measurement but as i switch into R it doesnt activate the sound part, speaker is 100% working (via direct test), "status" says that PDC is not activated
[PaSoft]
recognize it, gives me the chance to apply modifications by recoding and shows no errors (about this sw, can someone please explain me what the impulse/sec x32 is for?)
[DIS v.57] (this is beyond strange)
recognize it into fitted modules, if i do a test no errors are present, if i go ahead into activation part and I do a speaker test, then, PDC starts working normally, but ONLY if i keep the engine on or key into ON position, by turning the engine off seems as the car lost something. to make the PDC work again, i must go back and do the speaker test.
[NCS]
Ncs doesnt' shows it into available ECUs and it doesnt' allows me to add the VO code $507, the box with VO orders, in reality is not showing any code, this probably is given by some sort of profile error even if with the NCSdummy profile i've been able to code almost everything (I do not have Revtor's and Expertmode profile gave me errors).
 

·
Here to serve y’all
2004 330Ci 85k miles
Joined
·
11,110 Posts
Is it worth trying a used pdc module? (I'm no expert)
I agree. I suspect your PDC module was damaged either during the accident, the repair, or the false contact you mentioned. Get another, preferably newer, PDC module.
 

·
Sofa-king-what
Joined
·
1,928 Posts
Discussion Starter #9
I agree. I suspect your PDC module was damaged either during the accident, the repair, or the false contact you mentioned. Get another, preferably newer, PDC module.
Hi Bali
nope, PDC module is ok, i also tried with an other one and the situation stills the same.
i'm more concerned about what happens in NCS as even if i've ulpoaded a new revtor's profile (triple checked and is ok) the VO/FA pop up stills empty.
this means that PDC isn't loaded into the vehicle order, and for this not activated even if present,
for sure the speaker activation method is only a fake temporary activation.

what you think about the 1080 Coapi error??
 

·
Sofa-king-what
Joined
·
1,928 Posts
Discussion Starter #11
For what it's worth, I retrofitted PDC on my E46 and never added $507 to my VO and it works flawlessly. :dunno:
yeah but what if that still unrecognized under the modules in NCS, impossible to code via progman but present in inpa & Dis

i mean this is quite strange..

i repeat all the parts involved into PDC funtionality are working and there are no errors in diagnosis
 

·
//Binary is in my DNA
2002 BMW 325i
Joined
·
3,709 Posts

·
Sofa-king-what
Joined
·
1,928 Posts
Discussion Starter #18
Ok the procedure worked, now pdc is shown into the available modules under kmb and ews. ( also in progman now is available)

The problem is that it doesn’t activate.

In the E46ZST.000 file I’ve found some code for pdc

I used 508 which seems to be the standard one..
Plus some more...

Probably i choosed the wrong one??



Absolutely thanks as this is the correct procedure!!!
 

·
Sofa-king-what
Joined
·
1,928 Posts
Discussion Starter #20
Can you scan the PDC module for errors in INPA? I used BMW Scanner 1.4 to scan mine for errors.
No errors anywhere...


a friend of mine (more prone to NCS coding) told me NOT to use 508 as that is the 8 sensors pdc (FR/RR), to use instead the 507, this has 2 different code,, tried them both, none of them gave PDC...
WTF!!

I need to elaborate those C_03/2/1 and the relative functions
 
1 - 20 of 49 Posts
Top