E46 Fanatics Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hello,

I've been using my E46 (my first BMW) for over 2.5 years without any issue.
Couple days ago I accelerated from a parking lot and suddenly it beeped. This is the beep it usually gives when I drive with my parking brake on. I checked the parking brake but it was not ON. Then I saw that parking brake, ABS and traction control lights are all ON.

I was already on the road so I kept driving for couple of minutes until I found a place to stop the car. I turned off the engine and started again. It seemed all fine as no indicator lights were ON. But soon as I started to drive those 3 lights came back ON.

Then I parked the car again and put gear to drive and put the parking brake and let go of the brake (pedal). The car moved. I think I can safely say that the parking brakes are not working.

I kept driving anyway with the lights ON. After about 1 hour of driving I parked and went to a shopping mall and came back after about 2 hours. And then when I drove the lights were gone. No more indicator lights.

I thought the problem was fixed but unfortunately although there are no idicator lights ON, the parking brake doesnt seem to work. I tried couple of time putting the car on drive and checking with parking brake and it moved.

I would really appreciate any advice. I live in Japan and reparing a BMW is very costly as I need to take it to an agent. Even just to check with the computer they charge a lot.

Any information is appreciated.

Thank you.
 

·
Registered
Joined
·
249 Posts
I believe that the lights on the dash, and your non-functioning parking brake are NOT related. Just coincidence.
The 3 lights on your dash, that come and go, usually mean one or more of your wheel speed sensors are either gunked up, or on their way out, and need to be replaced.
Seach "wheel speed sensor", and you will see where they are, and how easy it is to pull them out, give them a quick clean, and reinstall. If the lights come on again, get the codes read, and they will be able to tell you exactly which one is faulty.
For you parking break issue, try tightenting the adjustment screws on the underside of your parking brake handle. If that doesn't work, you may need new parking brake shoes.
Good luck
 

·
Registered
Joined
·
727 Posts
Check the codes with a proper reader that can read the ABS module and KOMBI. It may be failing to communicate. Many BOSCH ABS modules have a problem with solder joints giving way over time causing intermittent failures... or it could be a wheel speed sensor... check it before you wreck it.
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
Thank you very much guys.
The indicator lights are not coming on anymore. The parking brake not working is the real problem. Now that I think about it I don't know since when it was not working. I can't remember the last time I used it. Just pull it when I stop, don't really bother to think if it works.

I will first try the screws under the handle.
Thank you.
 

·
Registered
Joined
·
3,288 Posts
I'm pretty sure your sensors need cleaning. I had something similar happen to me, although I didn't do anything about it and eventually it went away. Hasn't come back in over a year. I also frequently wash my car, about once a week so maybe that helped? lol. before that I only washed it once a month. So maybe those lights are code for "give me a bath bro"
 

·
Registered
Joined
·
1 Posts
My 328i has had the same three lights come on when ever the A/C or heated seats were on. I read somewhere that a low battery charge can cause funky issues with warning lights so I checked that first. The battery was still good but not fully charged. Looked at the alternator and noticed that the power steering fluid reservoir was leaking all over the alternator. My neighbour and I fixed the leak with a new $1.29 hose clamp and replaced the alternator. $230 later I can have all the accessories running and no dash lights have come on since. I'm happy it's fixed but annoyed that a cheap hose clamp was the start of the problems.
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top