BMW E46 Fanatics Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3,344 Posts
Discussion Starter #1
My car had a check engine light for about 12 hours.... the car drove fine with the CEL, but right before the CEL it felt like stalling and I was just standing in my driveway in N.

Anyway, after driving around some, the CEL just went away... maybe after driving 100 miles. I still got the car scanned at Advance Auto Parts because I know that the codes are stored... and it came up with this (only 1, thank God):

P0206
Injector Circuit
Open
Cylinder 6

So what does it mean exactly? and what could have caused it and how can I fix it (how much $?)

I'm not too worried, it seems like a minor fix, but since I am new to E46 I just want to be sure.

Oh btw, I did search... maybe I didnt search enough so I created a new thread.
 

·
Registered
Joined
·
5,018 Posts
Otherwise know as Crapy scanner syndrome its more than likely a misfire and that cheap scanner pulled the code wrong
 

·
Registered
Joined
·
3,344 Posts
Discussion Starter #3
So maybe just cyl 6 misfire?
 

·
Registered
Joined
·
5,018 Posts
That would be my guess
 

·
Registered
Joined
·
3,344 Posts
Discussion Starter #6
Yeah I know... I come from a VW background, and the Peake Tool equivalent is a VAGCOM lol...
I'll def look into that in the future, thanks.

Anyway, the CEL went away, so maybe its not that big of a deal. Maybe I'll look into changing the ignition coils....
Does each cylinder have its own coil?
 

·
Registered
Joined
·
3,344 Posts
Discussion Starter #8
OK so after driving around for a couple days normally, the light came on again, just a couple hours ago. The car runs really rough and will not accelerate... takes a while for it to get to speed and shakes violently. I'm guessing its misfiring now, and I'm also guessing that its due to the previous code for injector circuit. I cannot scan yet because I do not have my own scan tool nor a Peake tool.... so Ill have to wait till after lab tomorrow (7PM Eastern) but I'm pretty sure it has to do with the code that had a few days ago.

This is really getting to my head now... any idea where I should start to fix this problem (besides scanning of course)... injectors? coils? spark plugs?

Do you recommend any injector cleaner or something?

Also, one thing I noticed is, last time the CEL came on was when I had about 1/4 tank full.... then went away after driving around full tank, but it didnt shake like this. Now I'm back to 1/4 tank (now less) and maybe I have a dirty fuel filter and that's causing it?

I dont know what to do besides scanning.... I live like 4 hours away from the used car dealer I bought the car from, and I'm infinitely busy with classes and work. I dont want to drop off at BMW Dealer and have them charge me hundreds of dollars, and I want the used car dealer to fix it for free. Do you think its possible? It hasnt even been a week since I owned the car. I'm willing to return the car for full price if possible.
 

·
Registered
Joined
·
73 Posts
Does not accelerate? Shakes?

Sounds like Cyl. #6 isnt working?

Swap Coil + Spark plug #6 with #2 and I would assume the same thing will happen, get the new code reading and see if its still #6 (if its #6 again, prehaps injector problem) if (its #2 now, then coil or spark plugs or both)

Others here may have better ideas, hope this helps!
 

·
Registered
Joined
·
3,344 Posts
Discussion Starter #10 (Edited)
That sounds like it may work... but I dont know anything about changing coils by myself, etc. and I dont have any tools either even if I am a fast learner.

I pulled the codes about 1 hour ago and it gave me:

P0201
Injector Circuit
Open
Cylinder 1

P0206
Injector Circuit
Open
Cylinder 6

P1343
Manfacurer Contrl.
Ignition system or
Misfire

I want to change all plugs, coils, and injectors.... how much would that cost me?

:( = sad BMW owner.

[EDIT]

Did a search and there is a thread on here that has all the P-codes. P1343 means cyl. 1 misfire.
 

·
Registered
Joined
·
3,344 Posts
Discussion Starter #11
Update: got all the injectors cleaned by some mechanic, and he said he replaced two injectors but doesnt remember which two he replaced.

Car drove fine for a while, great.
Two days ago, same problem came back, and code this time is : P0201 Injector circuit open, Cylinder 1

Can someone please help me? Do I need to replace the entire injector or is there a way to fix this?
 

·
Registered
Joined
·
3,344 Posts
Discussion Starter #12
Seems like this only happens in cold weather (below 25 degrees F)
I unplugged coil #1 and drove it.... it drove really rough, but no check engine light lol. wth
 
1 - 12 of 12 Posts
Top