BMW E46 Fanatics Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
46 Posts
Discussion Starter #1
My car is 01 330i about 78,000miles on it.
Everything feels fine except I feel less power in last two months but not obviously.
I'm a student so I don't often drive a lot. mostly just do local driving. about one month ago I had a long drive about 3hrs. and that time I got my engine lingt on and throwed out P0174 but no other signals no rough idle. I deleted the code, and the car drives good after that. last weekend I had a 2hrs drive. and the code came out again P0174. Still, everything else feel good. Now I'm curious why long drive brings in this code? But local drive, even about one hour, is ok. That's weird. Besides, I don't get rough idle problem.
I made some search and this one gives me some hints
http://forum.e46fanatics.com/showthread.php?t=576774&highlight=p0174

I still need some help on this situation, which is the first one I should inspect on? MAF? or bad boot?
 

·
Registered
Joined
·
985 Posts
I had that code by itself about 2 years back and it was one of the cam position sensors. I ended up replacing both so I cannot remember whether it was the intake or exhaust one that fixed it. Maybe someone else can chime in?
 

·
Registered
Joined
·
46 Posts
Discussion Starter #3
I had that code by itself about 2 years back and it was one of the cam position sensors. I ended up replacing both so I cannot remember whether it was the intake or exhaust one that fixed it. Maybe someone else can chime in?
what's cam position sensors? where are they?
 
1 - 4 of 4 Posts
Top