E46 Fanatics Forum banner
1 - 20 of 28 Posts

·
Registered
2001 325ci
Joined
·
27 Posts
Discussion Starter · #1 ·
Hi,

So I just had a really strange problem this morning. While driving to work my 325ci started to stall when I applied the throttle. I was nearly at work and made it to the parking lot. At the parking lot I let the car idle while I used my OBD to read any fault codes. There were none.

While idling the car died. When I started it again, it would run for a second or two en die.

I called roadside assistance. After listening to the car he said it sounded like there was no fuel. He banged on the gas tank with a hammer to maybe get the fuel pump going while I was starting the car, but it made no difference. He then gave me a jerry can and told me to get 5L of gas from the gas station nearby.

After adding the gas, the car started immediately and ran smooth. I drove to the gas station and fill her up. So here comes the strange part.

The gas meter indicated that there was 1/4 left in the tank and the board computer indicated I could still drive 130km. I’ve added 5.67L trough the jerry can and I’ve added another 48.63L at the gas station (maybe I could have topped her of even more by 1 or 2L if I had waited). So 54.3L in total.

The fuel capacity of the E46 325ci is 65L. So this leads me to believe the fuel indicator and board computer aren't wrong. But when adding the first 5L she started immediately.

Any ideas?
 

·
Registered
Joined
·
20 Posts
My fuel pump did funny things like this without throwing out any error codes. I replaced the pump and that fixed the issue. I also think the fuel level sender is part of the fuel pump, at least it is on my M3. I was also having weird gas readings which also self corrected with the new pump.
 

·
Registered
2001 325ci
Joined
·
27 Posts
Discussion Starter · #4 · (Edited)
My fuel pump did funny things like this without throwing out any error codes. I replaced the pump and that fixed the issue. I also think the fuel level sender is part of the fuel pump, at least it is on my M3. I was also having weird gas readings which also self corrected with the new pump.
The pump has never been changed and the car is 21 years old and has driven 200.000KM. Guess it's time anyway, so let's give it a shot. Do I just need number 1 on this image? I see number 2 (Left fuel level sensor) and it seems like a different part. Not sure what I need:

White Font Line Parallel Art
 

·
Registered
Joined
·
20 Posts
The pump has never been changed and the car is 21 years old and has driven 200.000KM. Guess it's time anyway, so let's give it a shot. Do I just need number 1 on this image? I see number 2 (Left fuel level sensor) and it seems like a different part. Not sure what I need:

View attachment 965211
I bought the geniune bmw pump from Turner motorsport and it came with everything you need to change. Make sure that the fuel line clicks on before you go driving around, ask me how I know. Use a rubber mallet and a small pry bar to gently tap the ring loose. I hit mine with kroil before I tried to remove, let it sit and it came off easilly. You do not want to break the threaded part of the tank where the sealing collar screws in. That's a new tank if that happens.
 

·
Premium Member
Joined
·
4,839 Posts
I'd also confirm that your 'sucking jet pump' #3 is transferring fuel from the other side of the tank.

If it's clogged or has come disconnected, you'll still have roughly 1/4 tank, but be unable to use it.

t
 

·
Registered
2001 325ci
Joined
·
27 Posts
Discussion Starter · #16 ·
Buy the VDO fuel pump assembly.
I live in The Netherlands. I guess this aftermarket pump is ok? It's a CONTINENTAL/VDO:

 

·
Registered
2001 325ci
Joined
·
27 Posts
Discussion Starter · #19 · (Edited)
So, I've ordered the VDO pump. I just need the rubber seal shown on the image below. The problem is my car is from 2001 and the VIN-number shows two rubber seals. Called the dealer and they can't tell me which one I need neither.

So my only option would be to remove the installed fuel pump and look at the rubber seal to see I there's a number on it which corresponds to one of the two seals?
 

·
Administrator
2013 X1 M-sport
Joined
·
21,816 Posts
I just need the rubber seal shown on the image below. The problem is my car is from 2001 and the VIN-number shows two rubber seals. Called the dealer and they can't tell me which one I need neither.
This was just brought up recently in another thread. There is a seal on each side of the tank, right (passenger in USA) and left.
 
1 - 20 of 28 Posts
Top