E46 Fanatics Forum banner
1 - 8 of 8 Posts

· Registered
Joined
·
52 Posts
Discussion Starter · #1 ·
Hello guys!

I have a BMW 316i 2004 (N42B18A; 115hp) and I changed several things over the course of 3-4 weeks (have this car for about 7 weeks now). I changed the oil filter housing gasket, valve cover gasket, another gasket that I forgot the name of, the oil sump gasket, the oil level sensor, an engine mount and even my dipstick because the other one got stuck all the time. This cost me around 800 bucks including labour and oil. I'm just 5 days in and I had the light come up yesterday when shutting off my engine and then it didn't come back all day. This morning it turned on when driving and it went away and did not come back when shutting off. I checked my oil level this morning and it's just where it was (above the max a bit.) because I forgot that there was still some oil in the filter but that's not a big deal.:blah: Right now I just want to know why in the living hell does this light come on ? I have a feeling that the connector of the sensor is oily and was not cleaned but I'm not sure. Btw, all my parts are OEM including the sensor from HELLA
 

· Banned
Joined
·
4,173 Posts
Hello guys!

I have a BMW 316i 2004 (N42B18A; 115hp) and I changed several things over the course of 3-4 weeks (have this car for about 7 weeks now). I changed the oil filter housing gasket, valve cover gasket, another gasket that I forgot the name of, the oil sump gasket, the oil level sensor, an engine mount and even my dipstick because the other one got stuck all the time. This cost me around 800 bucks including labour and oil. I'm just 5 days in and I had the light come up yesterday when shutting off my engine and then it didn't come back all day. This morning it turned on when driving and it went away and did not come back when shutting off. I checked my oil level this morning and it's just where it was (above the max a bit.) because I forgot that there was still some oil in the filter but that's not a big deal.:blah: Right now I just want to know why in the living hell does this light come on ? I have a feeling that the connector of the sensor is oily and was not cleaned but I'm not sure. Btw, all my parts are OEM including the sensor from HELLA
For teh record oil is an insulator and doesn't conduct electricity so a bit of oil on the connector probably isn't going to be the cause. That's not to say that you shouldn't clean your connectors if they have become contaminated with oil because oil can damage the insulation causing wire to wire contact and a short circuit. So it would be the first place I would look given that you have installed a new oil level sensor. If you changed you sump gasket and OFHG because they were leaking then it's proably fair to say that your sensor cable and connector have taken some stick.
 

· Registered
Joined
·
52 Posts
Discussion Starter · #4 ·
As mentioned, all parts are OEM from BMW and the sensor (just like the original) is from Hella. I can verify the connector afterwards at home. And I think well actually I'm positive that is has taken a beating.
 

· Premium Member
2000 328i 5MT
Joined
·
2,158 Posts
The oil level sensor on these cars is an absolute joke. I installed a brand new hella last year and 3 weeks later it was on the fritz. I'm over it.
I've had to replace mine twice:

At 133k (April 2010) I installed an aftermarket oil sender.
At 210k (Dec. 2016) I installed an OEM oil sender (36k ago).

They should certainly last longer than 3 weeks. There is something else wrong.
 

· Registered
2004 325ci
Joined
·
2,469 Posts
I've had to replace mine twice:

At 133k (April 2010) I installed an aftermarket oil sender.
At 210k (Dec. 2016) I installed an OEM oil sender (36k ago).

They should certainly last longer than 3 weeks. There is something else wrong.
I bought it off eBay so probably the sensor was old or some fake. But in general I don't need a sensor to tell me my oil is low. That's why I have a dipstick.

Sent from my ONEPLUS A3000 using Tapatalk
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top