E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 6 of 6 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Probably the most common topic with the E46. I have a 2001 325xi with 142,000 miles on it. I've read a lot of peoples threads on this trying to figure out my problem. So ill start the list of problems I have.

1-Blue smoke on start ups sometimes.
2- Blue smoke if you rev the engine to a high rpm, let off the accelerator for a second and bring the engine to high rpm's again.
3- Blue smoke after when I slow down to merge onto onto another high way road.
4- I consume a quart of 10w-30 oil 500-700 miles

From what I understand this sounds live the valve stem seals and guides?

I bought a spare m54b25 motor for my car that was seized up. I finally got the motor to spin smoothly with my breaker bar. I have the cylinder head at the machine shop currently from my spare engine. I just want to make sure its not the rings, well at least other peoples opinions on my problems. My goal is to replace my cylinder head in a day cause i don't have much time on my hands.
Also, can someone link a DIY on changing piston rings? I might just rebuild the whole motor while I'm at it.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #3 ·
I'll give that a shot on my next day off, I got a chance to do a cylinder leak down test on my car. Just one cylinder had a significantly had a lot of air coming out from the exhaust compared to the others cylinders.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
The CCV and oil filter housing gasket was replaced by BMW right before I bought the car. I've replaced the CCV a second time after 20k miles. When I get a chance to do the compression test, I'll post the results.
 

·
Registered
Joined
·
7,063 Posts
Why do you have 10w30 oil in the car? When I used the wrong oil (M1 5w30), it burned it like a mofo. Put the right oil in it (0w30/0w40) and it worked fine.
 
1 - 6 of 6 Posts
Top