BMW E46 Fanatics Forum banner

1 - 20 of 28 Posts

·
me
Joined
·
10,376 Posts
Discussion Starter #1

BMW are being champions about it.

Wind back four weeks, I took my wheels off for a clean and thought I would check out the subframe mounting points due to all the problems that I see here. Noticed a 10mm hairline crack. Well out of warranty but I tell my friend at BMW about it and within a few hours get the call that they are covering the repair :thumbsup:

Car will be gone for approximately 2 months while they replace the floor. I have more photos that I will post up later. Unlike our counterparts accross the pond who seem to have the left mount fail, they say our right top mounting points are the most common.

The repair has the car pretty much stripped of everything electrical, no doors, no boot, no rear bumper, no exhaust, no boot, no rear seat, etc. They replace the floor and the boot. and then fill the new cavity with the hardening sealant for extra strength.

Cant wait to get her back, I miss her and shes only been gone 2 & a bit weeks.
 

Attachments

·
Registered
Joined
·
599 Posts
I had that happen on my 328ci and they took 3mths but gave me a lovely new 330 as a loan so I was happy and all warranty. But now I see it is on your m3 I am worried as I am putting down just on 500rwhp..I better have a look:banghead:
 

·
Registered
Joined
·
648 Posts
OK, so why does this happen - excessive forces the vehicle is not designed for (caused by modifications or hooning around) ?. Is it likely to happen under "normal" conditions ?
 

·
Registered
Joined
·
32 Posts
Heh, i remember the subframe had to be changed on my Skyline... it took a few hours...

I had better get my sub frame checked out too =\ . Did you buy your car new CortinaD??

This sounds like it would be a very expensive exercise .
 

·
me
Joined
·
10,376 Posts
Discussion Starter #9
My theory is its a motorsport car so its built to be driven hard. That said I haven't tracked it yet so its just city & country driving for me.

A couple of them are getting done at the moment so its not just mine but if you read the stuff on here and other bmw forums, it happens on all of them, stock or modified. It happens on all of them, the m cars less frequently from what I read.

Bought the car secondhand.

From what the repairer said they reenforce the area, I bought a TMS kit but have decided not to question BMW as they are saying this is the fix. If it goes again and they dont cover it though I will be putting the kit in. We will see, from what I hear they haven't had one fail that they have repaired.

Saintly: pics & specs of your weapon :)
 

·
Registered
Joined
·
599 Posts

·
me
Joined
·
10,376 Posts
Discussion Starter #19
Thanks:thumbsup: What mods do you have?
hardly any dude.

tv in motion
ice->link plus
alcantara zcp wheel
predator chromiums

Update: I bought a new rear bar as mine was a bit damaged, they are putting that back on today as the cars basically finished at the body shop (they are waiting for the bonding re-enforcement glue) to dry. It might be only a month now, they have worked fulltime on it to get it done. It goes to BMW on Tuesday.
 

·
me
Joined
·
10,376 Posts
Discussion Starter #20
shes backkkkkk

Oh yeah...they worked overtimes to get it back to me asap.

been driving it all arvo, no rattles which is amazing considering the state it was in.

:thumbsup: to BMW on this one.
 

Attachments

1 - 20 of 28 Posts
Top