E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of October's Ride of the Month Challenge!
1 - 10 of 10 Posts

·
Registered
Joined
·
174 Posts
Discussion Starter · #1 ·
Just did a full brake swap.. (rotors and pads) but now the E-brake is completely dead. And the button on the top of the handle is pressed at all times... Any ideas?
 

·
Registered
Joined
·
45 Posts
Did your rear brakes include the spring mechanism which the e-brake cable attaches to? It goes under the brake rotor and you are probably missing that.
 

·
Registered
Joined
·
220 Posts
does the ebrake engage when you hold the lever up? if so, maybe your button is stuck. try lifting the ebrake lever up, let it go and let itself slam down see if the button dislodges.
 

·
Registered
Joined
·
174 Posts
Discussion Starter · #4 ·
The button is lodged in... It will not release. I will try that.

Also when I did the brakes, I did not touch anything on the parking brake assembly. hopefully its just the button being stuck.
 

·
Registered
Joined
·
13,875 Posts
Happens to me quiet frequently.

What happens is when you push the button in, it moves a lever in the ebrake mechanism. The stop for the lever gets bent open, and the lever gets stuck against that stop.

What you have to do is take off teh ebrake boot. Then you should see a little lever, in my car it's black. It's pretty easy to spot against the metal. just push that back up into the mechanism. that should release the button. What i'd do after that is get some pliers and carefully bend that metal stop so it actually stops the lever, instead of getting it stuck.

if you need more help lmk, i can get pics if you really need them. (i might not check back in the thread so just pm me)
 

·
Registered
Joined
·
13,875 Posts
here are some pics by request.


You can see the metal tab in these pictures that needs to be bent back into shape.

The metal tab is what stops the button from going in too much. So you just have to bend it back. When you push the ebrake button, it should stop the black lever from going any further. As you can see, mine needs to be bent back into shape!
 

Attachments

·
Registered
Joined
·
474 Posts
Resurrecting an old thread, but I had to thank SL Blak Soldier for posting the pictures, and saving me a lot of frustration. Had a stuck e-brake button, and this was exactly what was causing the problem. :thumbup:
 
1 - 10 of 10 Posts
Top