E46 Fanatics Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 · (Edited)
Hi all, I just bought a 2004 M3 SMG LSB with everything package on it.. inpection I and II are done and also got the record in hand and everything is ok. It's my first time to drive and own an M3 and kinda confused on shifting, I am aware that it has a clutch, but for some reason, when I shift from Neutral to Reverse or 1S or 1D, I get this short grinding or buzzing noise, but when the car is on the road.. it shifts perfectly and very smoothly.. only when It shift down to 2nd and 1st gear and on full stop it does it again, I have checked other forums and I didn't understand much of what they're telling as I am not realy experienced on car mechanics.. BUT I manage to read something that is pretty simillar in my case and all he did was replace the Hydraulic fluid, the guy wasn't specific tho but I am assuming he is reffering to the SMG Hydraulic oil, the question is, how do I change the oil correctly? do I need to pump it out? do I need to do some shifting? because most forums that I've read starts with SMG hydraulic oil and ends up on the actual transmission(bleading it from under).

Also, sometimes when Im on full stop and shifted to 1D or 1S, when I take off.. the car do hiccups, and when that happens, I need to slap the shifter to D or S depending on where I'm at..
 

·
Registered
Joined
·
1,058 Posts
the buzzing sound you might be hearing could be the pump "priming" like you hear when you unlock your car. mine does it from time to time. the hiccups you feel might be the clutch slipping a little, my car does it every now and then, nothing too serious.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #4 ·
I got it!! it shifts fine now.. I checked the SMG Hydraulic oil and it barely touched the gauge =(, now I filled it just right below the max line.. shifts fine now although sometimes it will still give me that buzzing sound like air on a hose.. but after 2 or 3 shifts back and fort.. it's gone :D
 

·
Registered
Joined
·
288 Posts
I got it!! it shifts fine now.. I checked the SMG Hydraulic oil and it barely touched the gauge =(, now I filled it just right below the max line.. shifts fine now although sometimes it will still give me that buzzing sound like air on a hose.. but after 2 or 3 shifts back and fort.. it's gone :D
What did you fill it with?
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top