BMW E46 Fanatics Forum banner

61 - 80 of 92 Posts

·
Registered
Joined
·
1,791 Posts
bump.

ok, so everything went magically.

UNTIL i reinstalled everything. It all ran well....opened and closed just about perfectly (i replaced various corroded clips)

the only thing that will not work is when i shut it, it will not level to the appropriate roof height! :banghead:

so naturally i followed step #5 in this tut. and it told me this was a common problem that can be solved by adjusting the motor.

after about LITERALLY 2 hours, no only does it not work, but its gotten worse than it was when i ****ing started :banghead::banghead::banghead::banghead::banghead:

can someone please let me know what i actually am supposed to do??!?!?!?!?

currently, the motor now starts to drag and slow down to the point where im concerned it will break. THIS DID NOT HAPPEN WHEN I BEGAN

what is going on>!:thumbdwn::thumbdwn:
 

·
Registered
Joined
·
3 Posts
I heard a grinding noise coming from my sunroof and I assumed it was the driver side clips. I took the glass off only to discover the rain gutter was dislocated and burried into the back. The locking pins which are designed to keep the rain gutter in place were both broken and missing. Does anyone know if they can be ordered ( I didn't see them on realoem) or it there a DIY way to keep the rain gutter fastened? I need to buy a replacement gutter, and I want to get all parts in one shot. Thanks for any and all assistance. Peter
 

Attachments

·
Registered
Joined
·
90 Posts
Thanks for sharing this. My liner is messed up too and this DIY is on my list (after shocks, end links, driver's door lock, bumper, fogs, clear corners....)
 

·
Registered
Joined
·
20 Posts
PLEASE HELPP!!
i got my cassette replaced on my sunroof a little over a year ago. it worked great, until yesterday. I got in my car, (2003 325xi) when to hit the botton and it just clicked-- one time. Up, forward, backward- every direction, every time, i would push the botton and it would just click once, and nothing would happen. I took it to a mechanic, he said the motor was shot. asked for about $400 plus bucks!! i went online, motors arnt too expensive. my question is, is this a simple/manageable DIY project. if i just buy the motor myself and install it? is there a possibility I could run into a something else wrong with it-- maybe a common related issue?

ive been trying to find a nice DIY link for motor issues but im having difficulty finding someone who has had a similar problem
 

·
Registered
Best M5 Ever Made!
Joined
·
6,438 Posts
bump.

ok, so everything went magically.

UNTIL i reinstalled everything. It all ran well....opened and closed just about perfectly (i replaced various corroded clips)

the only thing that will not work is when i shut it, it will not level to the appropriate roof height! :banghead:

so naturally i followed step #5 in this tut. and it told me this was a common problem that can be solved by adjusting the motor.

after about LITERALLY 2 hours, no only does it not work, but its gotten worse than it was when i ****ing started :banghead::banghead::banghead::banghead::banghead:

can someone please let me know what i actually am supposed to do??!?!?!?!?

currently, the motor now starts to drag and slow down to the point where im concerned it will break. THIS DID NOT HAPPEN WHEN I BEGAN

what is going on>!:thumbdwn::thumbdwn:
Posting in here because I'll probably need to do this on the wife's car soon.

To answer your question, I believe that when you fasten the last three torx bolts on either side, they do not go directly into a straight hole, but can be adjusted to raise or lower the actual glass... maybe I read that from Delmarco somewhere? it was in another DIY for this same thing awhile back... I am pretty sure it was Delmarco, PM him..

no clue what you did to your motor, lol.
 

·
Registered
Joined
·
1,791 Posts
Posting in here because I'll probably need to do this on the wife's car soon.

To answer your question, I believe that when you fasten the last three torx bolts on either side, they do not go directly into a straight hole, but can be adjusted to raise or lower the actual glass... maybe I read that from Delmarco somewhere? it was in another DIY for this same thing awhile back... I am pretty sure it was Delmarco, PM him..

no clue what you did to your motor, lol.
yeah I ended up fixing that by a combo of manually cranking it to the right position as well as adjusting the screws like you said. Then afterwards, I simply did the reset by holding the button in the closed position for ~15 seconds. However, this didnt fix the entire problem. As of now, everything works 100% as long as I don't even pull the sunshade closed. If I do that, all hell breaks loose. But considereing that is a very small issue I decided to live with the sunroof always see through :hi:

So with the sunshade open, everything is good to go
 

·
Registered
Joined
·
16 Posts
Is there an adjustment on the sliding tracks?

The problem I am having is the rear passenger corner is dropping about 1/4" to 3/8" lower than the other 3 corners. Sometimes when closing the sunroof, it gets about 4" from closing and stops and opens fully. We kept pushing the button til it closed fully. That is when I read about the reset. I tried the reset and it at least let the sunroof close. When I tilt it up I took these pics and you can see that something is off. You can see in the drivers side is about 1" ahead of the passenger side. Is there an adjustment on the sliding tracks?

Pics were taken after I tried the reset.....



Closed



Tilted




Thanks for any suggestions.
PS....The car has been washed since the pics.....LOL
 

·
Registered
Joined
·
1,958 Posts
When I try to open my sunroof, it opens about 30-40% before I hear a *CLACK* and then it proceeds to close on its own. Am I having the same problem as everyone else in this thread?
 

·
Registered
Joined
·
16 Posts
When I try to open my sunroof, it opens about 30-40% before I hear a *CLACK* and then it proceeds to close on its own. Am I having the same problem as everyone else in this thread?
You are not having the same problems as me. Did you read the problems others are having?
 

·
Registered
Joined
·
7 Posts
I was about to do this diy but wanted to see if any clips were broken at all first. Took the sunroof off and turns out none of my clips were broken, I just had a buildup of grease that turned into glue. cleaned it all out and put some new grease, good as new now
 

·
Registered
Joined
·
581 Posts
When I try to open my sunroof, it opens about 30-40% before I hear a *CLACK* and then it proceeds to close on its own. Am I having the same problem as everyone else in this thread?
Check your clips and alignment of the entire system as well as the shade cover.

If not, the track coils have misaligned and its a royal PITA to fix.
 

·
Registered
Joined
·
44 Posts
Hi Comrads,

Bought my car a few weeks ago, long story short, the dealer replaced my sun roof, what maint needs to be done? Grease? Any special kind? How often?

Thanks
Dave
 

·
Registered
Joined
·
67 Posts
anybody know if this piece is plastic or metal? It's the only thing I need and I don't want to buy the whole repair kit for this one tiny piece! I may try to concoct something…
 

Attachments

·
Registered
Joined
·
32 Posts
Enclosed is pic of the new and improved sunshade driver

old one on left new on right. This is part of the sunroof repair kit
Has anyone ever figured out a reasonable method for replacing this driver piece? Removing the headliner sounds like an awful lot of stress, based on my prior experience with cheapie plastic clips & weakly glued panel materials. I can foresee a lot of snapping clips and 'oh sh*ts' followed by endless trolling for expensive replacement trim parts.

Also, I bought the sunroof repair kit, and it comes with the left side clips for a 09/2003+ model with the holes drilled in the wrong place. If you order the kit, you need to also order the left clip PN 54138246027.

Update: The answer is 'Yes', headliner gotta come out. http://forum.e46fanatics.com/showthread.php?t=1009411
 
61 - 80 of 92 Posts
Top