E46 Fanatics Forum banner
  • Hey everyone! Enter your ride HERE to be a part of this month's Ride of the Month Challenge!

1 - 11 of 11 Posts

·
Registered
Joined
·
230 Posts
Discussion Starter · #1 ·
My car is stalling when my AC is on, Also a huge loss of power.. I had vacuum leak which i corrected 2 months ago. The Vanos seals where replaced a year ago which makes me think that might not be the source of the problem. SES light is on with a P0344 intermittent camshaft bank 1. Any help will be much appreciated.
thanks.
 

·
Registered
Joined
·
196 Posts
My car is stalling when my AC is on, Also a huge loss of power.. I had vacuum leak which i corrected 2 months ago. The Vanos seals where replaced a year ago which makes me think that might not be the source of the problem. SES light is on with a P0344 intermittent camshaft bank 1. Any help will be much appreciated.
thanks.
Maybe a damaged compressor (bad bearing or something like that)... causing extra load to the engine.

this was the first that came to my mind...
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #3 ·
I replaced the pulleys and the belts not even 1k miles ago. Can it be fuel pump? even though I have not pump codes?
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #5 ·
I'll check into that. Any other suggestions while in down there? lol
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #7 ·
I might go with the camshaft since the OS issue is mostly on cold weather I guess.
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #9 ·
nahh man, I have not do anything yet.
 

·
Registered
Joined
·
5,417 Posts
Since you are throwning a code for a cps i would think that would most likely be your problem. Thats where I would start. Find out if its exhaust or intake and get to replacing. Cam sensors cause driveability issues as well as stalling issues.
 

·
Registered
Joined
·
230 Posts
Discussion Starter · #11 ·
Thanks man
 
1 - 11 of 11 Posts
Top